<!doctype html>
<!--[if lt IE 7]><html lang="en-US"
	prefix="og: https://ogp.me/ns#"  class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US"
	prefix="og: https://ogp.me/ns#"  class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US"
	prefix="og: https://ogp.me/ns#"  class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"
	prefix="og: https://ogp.me/ns#"  class="no-js"><!--<![endif]-->

	<head>
		<meta charset="utf-8">

				<meta http-equiv="X-UA-Compatible" content="IE=edge">

		<title>Scientist Claims Alien &quot;Octopus-like Creatures&quot; May Be Living on Jupiter&#039;s Moon Europa | Mysterious Universe</title>

				<meta name="HandheldFriendly" content="True">
		<meta name="MobileOptimized" content="320">
		<meta name="viewport" content="width=device-width, initial-scale=1"/>

				<link rel="apple-touch-icon" href="https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/images/apple-touch-icon.png">
		<link rel="apple-touch-icon-precomposed" href="https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/images/apple-touch-icon-152x152-precomposed.png">
		<link rel="icon" href="https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/favicon.png">
		<!--[if IE]>
			<link rel="shortcut icon" href="https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/favicon.ico">
		<![endif]-->
				<!-- <meta name="msapplication-TileColor" content="#f01d4f"> -->
		<!-- <meta name="msapplication-TileImage" content="https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/images/win8-tile-icon.png"> -->
        <meta name="theme-color" content="#160036">

		<link rel="pingback" href="https://mysteriousuniverse.org/xmlrpc.php">

		<meta name="apple-itunes-app" content="app-id=721204906"/>
		<meta name="google-site-verification" content="8FEi3BSJzzc5JxD6PZJOoqRFYQiyF22ZBDM6tnY6rxc" />
		<script type="text/javascript">
		window.google_analytics_uacct = "UA-10374297-1";
		</script>

				
<!-- All in One SEO Pack 3.3.4 by Michael Torbert of Semper Fi Web Design[574,706] -->
<meta name="description"  content="A British scientist claims it&#039;s highly likely there&#039;s life on Jupiter&#039;s moon Europa and it could be in the form of intelligent octopus-like creatures." />

<meta name="keywords"  content="europa,octopus,jupiter,bizarre,dinosaur,life on other planets,pterosaur,science,space,squid,news,space &amp; astronomy" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mysteriousuniverse.org/#organization","url":"https://mysteriousuniverse.org/","name":"Mysterious Universe","sameAs":[]},{"@type":"WebSite","@id":"https://mysteriousuniverse.org/#website","url":"https://mysteriousuniverse.org/","name":"Mysterious Universe","publisher":{"@id":"https://mysteriousuniverse.org/#organization"}},{"@type":"WebPage","@id":"https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/#webpage","url":"https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/","inLanguage":"en-US","name":"Scientist Claims Alien &#8220;Octopus-like Creatures&#8221; May Be Living on Jupiter&#8217;s Moon Europa","isPartOf":{"@id":"https://mysteriousuniverse.org/#website"},"image":{"@type":"ImageObject","@id":"https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/#primaryimage","url":"https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-e1581245645989.jpg","width":1366,"height":679},"primaryImageOfPage":{"@id":"https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/#primaryimage"},"datePublished":"2020-02-10T10:25:26+11:00","dateModified":"2020-02-09T11:22:17+11:00","description":"A British scientist claims it's highly likely there's life on Jupiter's moon Europa and it could be in the form of intelligent octopus-like creatures. "},{"@type":"Article","@id":"https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/#article","isPartOf":{"@id":"https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/#webpage"},"author":{"@id":"https://mysteriousuniverse.org/author/paulseaburn/#author"},"headline":"Scientist Claims Alien &#8220;Octopus-like Creatures&#8221; May Be Living on Jupiter&#8217;s Moon Europa","datePublished":"2020-02-10T10:25:26+11:00","dateModified":"2020-02-09T11:22:17+11:00","commentCount":0,"mainEntityOfPage":{"@id":"https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/#webpage"},"publisher":{"@id":"https://mysteriousuniverse.org/#organization"},"articleSection":"Bizarre, News, Space &amp; Astronomy, Bizarre, dinosaur, life on other planets, octopus, Pterosaur, Science, space, squid","image":{"@type":"ImageObject","@id":"https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/#primaryimage","url":"https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-e1581245645989.jpg","width":1366,"height":679}},{"@type":"Person","@id":"https://mysteriousuniverse.org/author/paulseaburn/#author","name":"Paul Seaburn","sameAs":["https://www.facebook.com/paul.seaburn","https://twitter.com/paulseaburn"]}]}</script>
<link rel="canonical" href="https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/" />
<meta property="og:type" content="blog" />
<meta property="og:title" content="Scientist Claims Alien &quot;Octopus-like Creatures&quot; May Be Living on Jupiter&#039;s Moon Europa | Mysterious Universe" />
<meta property="og:description" content="A British scientist claims it&#039;s highly likely there&#039;s life on Jupiter&#039;s moon Europa and it could be in the form of intelligent octopus-like creatures." />
<meta property="og:url" content="https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/" />
<meta property="og:site_name" content="Mysterious Universe" />
<meta property="og:image" content="https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-e1581245645989-640x318.jpg" />
<meta property="fb:admins" content="508967392" />
<meta property="og:image:secure_url" content="https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-e1581245645989-640x318.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Scientist Claims Alien &quot;Octopus-like Creatures&quot; May Be Living on Jupiter&#039;s Moon Europa | Mysterious Universe" />
<meta name="twitter:description" content="A British scientist claims it&#039;s highly likely there&#039;s life on Jupiter&#039;s moon Europa and it could be in the form of intelligent octopus-like creatures." />
<meta name="twitter:image" content="https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-e1581245645989-640x318.jpg" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.3 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.3';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-10374297-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-10374297-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mysteriousuniverse.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<style type="text/css">
.powerpress_player .wp-audio-shortcode { max-width: 570px; }
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='https://mysteriousuniverse.org/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://mysteriousuniverse.org/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='ewd-ufaq-style-css'  href='https://mysteriousuniverse.org/wp-content/plugins/ultimate-faqs/css/ewd-ufaq-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='ewd-ufaq-rrssb-css'  href='https://mysteriousuniverse.org/wp-content/plugins/ultimate-faqs/css/rrssb-min.css' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='//fonts.googleapis.com/css?family=Exo%3A400%2C500italic%2C500%2C400italic%2C700italic%2C700%2C100italic%2C100%2C200italic%2C200%2C300italic%2C300' type='text/css' media='all' />
<link rel='stylesheet' id='bones-stylesheet-css'  href='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/css/style.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/css/ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mu-dropkick-css'  href='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/js/dropkick.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,mp3,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/mysteriousuniverse.org","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/js/libs/modernizr.custom.min.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/js/jquery.flexslider-min.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/js/clipboard.min.js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/zxcvbn/4.2.0/zxcvbn.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/js/libs/jquery.fitvids.js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/materialize/0.98.0/js/materialize.min.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/js/dropkick.2.1.9.min.js'></script>
<script type='text/javascript' async="async" src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<link rel='https://api.w.org/' href='https://mysteriousuniverse.org/wp-json/' />
<link rel='shortlink' href='https://mysteriousuniverse.org/?p=156946' />
<link rel="alternate" type="application/json+oembed" href="https://mysteriousuniverse.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmysteriousuniverse.org%2F2020%2F02%2Fscientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mysteriousuniverse.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmysteriousuniverse.org%2F2020%2F02%2Fscientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa%2F&#038;format=xml" />
<script type="text/javascript"> var googletag = googletag || {}; googletag.cmd = googletag.cmd || []; var pbjs = pbjs || {}; pbjs.que = pbjs.que || []; </script>
<script type="text/javascript" async src="https://adncdnend.azureedge.net/adn-hb/adn.mu.js"></script>

<script>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</script>
<script>
	(function () {
	    var node = document.getElementsByTagName('script')[0],
		rvbP = document.createElement('script');
	    window.CMT = { appId: 'c28258c1-3c87-4fa3-9a6f-e2d08e9b86af' };
	    rvbP.defer = true;
	    rvbP.type = 'text/javascript';
	    rvbP.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
			'//revboostprocdnadsprod.azureedge.net/scripts/latest/min.js';
	    node.parentNode.insertBefore(rvbP, node);
	})();
</script><script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
    <script type="text/javascript">
        var ajaxurl = 'https://mysteriousuniverse.org/wp-admin/admin-ajax.php';
    </script>
<!-- Running WishList Member v3.1.6583 -->
<style type='text/css'>
/* CSS Code for the Registration Form */

/* The Main Registration Form Table */
.wpm_registration{
	clear:both;
	padding:0;
	margin:10px 0;
}
.wpm_registration td{
	text-align:left;
}
/*CSS for Existing Members Login Table*/
.wpm_existing{
	clear:both;
	padding:0;
	margin:10px 0;
}
/* CSS for Registration Error Messages */
p.wpm_err{
	color:#f00;
	font-weight:bold;
}

/* CSS for custom message sent to registration url */
p.wlm_reg_msg_external {
	border: 2px dotted #aaaaaa;
	padding: 10px;
	background: #fff;
	color: #000;
}

/* CSS Code for the Registration Instructions Box */

/* The Main Instructions Box */
div#wlmreginstructions{
	background:#ffffdd;
	border:1px solid #ff0000;
	padding:0 1em 1em 1em;
	margin:0 auto 1em auto;
	font-size:1em;
	width:450px;
	color:#333333;
}

/* Links displayed in the Instructions Box */
#wlmreginstructions a{
	color:#0000ff;
	text-decoration:underline;
}

/* Numbered Bullets in the Instructions Box */
#wlmreginstructions ol{
	margin:0 0 0 1em;
	padding:0 0 0 1em;
	list-style:decimal;
	background:none;
}

/* Each Bullet Entry */
#wlmreginstructions li{
	margin:0;
	padding:0;
	background:none;
}


/* The Main Widget Enclosure */
.WishListMember_Widget{ }


/* The Main Login Merge Code Enclosure */
.WishListMember_LoginMergeCode{ }
</style>		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

.ob-smartfeed-wrapper {
	margin: 0 auto;
	max-width: 1290px;
}

ul.mu-tabs a.download-button {
	display:none;
}

.single-post-sidebar .widget_text {
	height: auto !important;
}

.mu-banner-ad {
	text-align: center;
	margin: 25px 0;
}

@media only screen and (min-width: 1000px) {
	.home-1000-area-1-sidebar .widget .textwidget {
		padding-top: 25px;
	}
}

/* Gforms Fixes */

.dk-select-open-down {
	margin-left: 0;
	padding-left: 0;
	padding-right: 0;
}

.gform_body .ginput_container_select div:last-of-type {
	width: 100%;
}

.page-contact-us .entry-content #field_1_5 {
	margin-bottom: 76px;
}

.entry-content .gform_body ul li, .entry-content:not(.no-rainbow) .gform_body ul li {
	padding-left: 0;
}

.ginput_container_email, .ginput_container_text,
.ginput_container_textarea {
	border-top: thin solid #999; 
}

.gform_body label {
	color: #999;
}		</style>
				
						

	</head>

	<body class="post-template-default single single-post postid-156946 single-format-standard fullwidth-podcast-image" itemscope itemtype="http://schema.org/WebPage">

		<div id="container">
		
			<header class="header" role="banner" itemscope itemtype="http://schema.org/WPHeader">

				<div id="inner-header" class="wrap cf inner-header">

											
					<label class="mobile-menu-btn icon-menu_big"></label>

					<h1 class="logo" itemscope itemtype="http://schema.org/Organization"><a href="https://mysteriousuniverse.org" rel="nofollow"><img src="https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/images/@2x-mu-logo.png"></a></h1>

										
					<nav role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
						<ul id="menu-main-menu" class="nav top-nav main cf"><li id="menu-item-88703" class="plus border start menu-item menu-item-type-post_type menu-item-object-page menu-item-88703"><a href="https://mysteriousuniverse.org/plus/">Plus+</a></li>
<li id="menu-item-88713" class="app menu-item menu-item-type-post_type menu-item-object-page menu-item-88713"><a href="https://mysteriousuniverse.org/app/">App</a></li>
<li id="menu-item-88717" class="store end menu-item menu-item-type-custom menu-item-object-custom menu-item-88717"><a href="http://mysteriousuniverse.org/shop">Store</a></li>
<li id="menu-item-14548" class="podcasts start border menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14548"><a href="https://mysteriousuniverse.org/category/podcasts/">Podcasts</a></li>
<li id="menu-item-88738" class="popular end menu-item menu-item-type-post_type menu-item-object-page menu-item-88738"><a href="https://mysteriousuniverse.org/latest/">Latest</a></li>
<li id="menu-item-88720" class="categories start border end menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-88720"><a href="#">Categories</a>
<ul class="sub-menu">
	<li id="menu-item-88745" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88745"><a href="https://mysteriousuniverse.org/latest/">Latest</a></li>
	<li id="menu-item-88723" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88723"><a href="https://mysteriousuniverse.org/category/news/">News</a></li>
	<li id="menu-item-88724" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88724"><a href="https://mysteriousuniverse.org/category/ancient/">Ancient Mysteries</a></li>
	<li id="menu-item-88725" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88725"><a href="https://mysteriousuniverse.org/category/bizarre/">Bizarre</a></li>
	<li id="menu-item-88726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88726"><a href="https://mysteriousuniverse.org/category/conspiracy/">Conspiracy</a></li>
	<li id="menu-item-88752" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88752"><a href="https://mysteriousuniverse.org/category/cryptozoology/">Cryptozoology</a></li>
	<li id="menu-item-88753" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88753"><a href="https://mysteriousuniverse.org/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-88754" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88754"><a href="https://mysteriousuniverse.org/category/ghostshauntings/">Ghosts &#038; Hauntings</a></li>
	<li id="menu-item-88755" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88755"><a href="https://mysteriousuniverse.org/category/modernmystery/">Modern Mysteries</a></li>
	<li id="menu-item-88757" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88757"><a href="https://mysteriousuniverse.org/category/naturalworld/">Natural World</a></li>
	<li id="menu-item-88759" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88759"><a href="https://mysteriousuniverse.org/category/plus-articles/">Plus+ Articles</a></li>
	<li id="menu-item-88798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88798"><a href="https://mysteriousuniverse.org/category/plus-podcasts/">Plus+ Podcasts</a></li>
	<li id="menu-item-88799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88799"><a href="https://mysteriousuniverse.org/category/podcasts/">Podcasts</a></li>
	<li id="menu-item-88800" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88800"><a href="https://mysteriousuniverse.org/category/psychedelics/">Psychedelics</a></li>
	<li id="menu-item-88801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88801"><a href="https://mysteriousuniverse.org/category/scitech/">Science &#038; Technology</a></li>
	<li id="menu-item-88802" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88802"><a href="https://mysteriousuniverse.org/category/spaceastronomy/">Space &#038; Astronomy</a></li>
	<li id="menu-item-88803" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88803"><a href="https://mysteriousuniverse.org/category/spirituality/">Spirituality</a></li>
	<li id="menu-item-88804" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88804"><a href="https://mysteriousuniverse.org/category/ufo-phenomenon/">UFO Phenomenon</a></li>
	<li id="menu-item-88805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88805"><a href="https://mysteriousuniverse.org/category/video/">Video</a></li>
</ul>
</li>
					

						
													
							<li class="start border end "><a href="https://mysteriousuniverse.org/log-in" title="Login">Log In</a></li>							
												
						</ul>

						
					</nav>

					<form role="search" method="get" id="searchform" class="search-form border" action="https://mysteriousuniverse.org/">
    <div>
        <label for="s" class="screen-reader-text">Search</label>
        <input type="search" id="s" name="s" value="" />

        <button type="submit" id="search-button" class="icon-search_big"></button>
    </div>
</form>					
				</div>

			</header>

			<div id="content">

				<div id="inner-content" class="wrap cf">
					
					<main id="main" class="m-all t-all d-5of7 cf " role="main" itemscope itemprop="mainContentOfPage" itemtype="http://schema.org/Blog">
					
					<!-- Added by Rena for Adimation -->
					<!-- /30438525/MysteriousUniverse/MU_Player -->
										<div id='div-gpt-ad-1523538705660-0' style='height:270px; width:480px;position: fixed; bottom:0; right:0; z-index: 44444;'>
					<script>
					googletag.cmd.push(function() { googletag.display('div-gpt-ad-1523538705660-0'); });
					</script>
					</div>
					 

						
							
              
              
              <article id="post-156946" class="cf post-156946 post type-post status-publish format-standard has-post-thumbnail hentry category-bizarre category-news category-spaceastronomy tag-bizarre tag-dinosaur tag-life-on-other-planets tag-octopus tag-pterosaur tag-science tag-space tag-squid" role="article" itemscope itemprop="blogPost" itemtype="http://schema.org/BlogPosting">

                <header class="article-header entry-header">

                  
                  <div class="image full"  style='background-image: url("https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-e1581245645989.jpg");' >

                                          <div class="inner-image full" >

                        
                      </div>


                    
                    
                     
                      <h6><ul class="post-categories">
	<li><a href="https://mysteriousuniverse.org/category/bizarre/" rel="category tag">Bizarre</a></li>
	<li><a href="https://mysteriousuniverse.org/category/news/" rel="category tag">News</a></li>
	<li><a href="https://mysteriousuniverse.org/category/spaceastronomy/" rel="category tag">Space &amp; Astronomy</a></li></ul></h6>

                      
                    
                  </div>

                      <div class="bar-message">
      <div class="message"><div><div><div>
      <!--         MU<a href="/plus" class="pluse-button">PLUS+</a>  
       -->

      <strong>Join Plus+ and get exclusive shows and extensions!</strong> Subscribe Today!       </div></div></div></div>
      <div class="learn-more">
              <a href="/plus" class="learn-button">LEARN MORE</a>
            </div>
    </div>            
    
                  <div class="header-bottom">
                    <h1 class="entry-title single-title" itemprop="headline" rel="bookmark">Scientist Claims Alien &#8220;Octopus-like Creatures&#8221; May Be Living on Jupiter&#8217;s Moon Europa</h1>

                    <p class="byline entry-meta vcard single">
                       <span class="entry-author author" itemprop="author" itemscope itemptype="http://schema.org/Person"><a href="https://mysteriousuniverse.org/author/paulseaburn/">Paul Seaburn</a></span> <time class="updated entry-time" datetime="2020-02-10" itemprop="datePublished"><a href="https://mysteriousuniverse.org/2020/02/10">February 10, 2020</a></time>                    </p>

                    <ul class="social-links">                 
                        <li class="facebook">
                            <a onclick="window.open('http://www.facebook.com/sharer.php?u=https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/&amp;t=Scientist Claims Alien &#8220;Octopus-like Creatures&#8221; May Be Living on Jupiter&#8217;s Moon Europa','','width=650,height=400'); return false;" href="#"><span class="icon-facebook2"></span>Facebook</a>
                        </li>
                        <li class="twitter">
                            <a data-url="https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/" onclick="window.open('http://twitter.com/share?Scientist Claims Alien &#8220;Octopus-like Creatures&#8221; May Be Living on Jupiter&#8217;s Moon Europa&amp;url=https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/','','width=742,height=370'); return false;" href="#"><span class="icon-twitter"></span>Twitter</a>
                        </li>
                        <li class="google">
                            <a onclick="window.open('https://plus.google.com/share?url=https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/','','height=550,width=350,left=100,top=100,menubar=0'); return false;" href="#"><span class="icon-google-plus"></span>Google+</a>
                        </li>
                    </ul>   
                  </div>

                </header> 
                <section class="entry-content cf" itemprop="articleBody">
				<!-- /30438525/MysteriousUniverse/mysteriousu_topbanner_article -->
				<div id='div-gpt-ad-1500210453292-0'>
				<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500210453292-0'); });
				</script>
				</div>

				
                  <p>As we wait in anticipation for future life-seeking missions to Mars, asteroids and other space bodies in our solar system, speculation that these probes will find life forms is increasing, but most scientists agree that it will be bacteria or other microorganisms. One who doesn’t is leading British space scientist Professor Monica Grady.</p><!-- /30438525/MysteriousUniverse/mysteriousu_midbanner_article_1 -->
<div id='div-gpt-ad-1500210453292-1' style="text-align: center;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500210453292-1'); });
</script>
</div>
<blockquote><p>&#8220;If there is something on Mars, it&#8217;s likely to be very small—bacteria. But I think we&#8217;ve got a better chance of having slightly higher forms of life on Europa, perhaps similar to the intelligence of an octopus.&#8221;</p></blockquote>
<img class="alignnone size-medium wp-image-134859" src="https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-1-570x387.jpg" alt="" width="570" height="387" srcset="https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-1-570x387.jpg 570w, https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-1-768x522.jpg 768w, https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-1-640x435.jpg 640w, https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-1.jpg 1920w" sizes="(max-width: 570px) 100vw, 570px" />
<p>In a recent speech at Liverpool Hope University (<a href="https://phys.org/news/2020-02-certainty-life-europa-mars-uk.html" target="_blank" rel="noopener noreferrer">covered by Phys.org)</a>, her first as the school’s new Chancellor, Grady explained that she’s confident Europa is home to higher-level life forms, but they’re in lower-level realms than on the surface. It’s slightly smaller than Earth’s moon but covered with a 15-mile thick layer of ice. That ice would protect creatures living underneath it from deadly solar radiation and asteroids – Europa’s atmosphere is too thin to protect it or support life. On the other hand, it’s likely that underneath all of the ice is liquid water of the salty kind, and hydrothermal vents that could spark the creation of life and then provide an environment to support it. If this sounds like Earth, Grady agrees.</p><!-- /30438525/MysteriousUniverse/mysteriousu_midbanner_article_2 -->
<div id='div-gpt-ad-1500210453292-2' style="text-align: center;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500210453292-2'); });
</script>
</div>
<blockquote><p>“&#8221;But I think it&#8217;s highly likely there will be life elsewhere—and I think it&#8217;s highly likely they&#8217;ll be made of the same elements. Humans evolved from little furry mammals that got the opportunity to evolve because the dinosaurs were killed by an asteroid impact. That is probably not going to happen on every planet—but it&#8217;s at least possible based purely on a statistical argument.”</p></blockquote>
<p>But octopuses?</p>
<blockquote><p>“I’m fairly specified we’re all there is at our amount of intelligence in this planetary method. And even if there are octopuses on Europa, that does not give us a cause to damage our planet.”</p></blockquote>
<div id="attachment_146323" style="width: 580px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-146323" class="size-medium wp-image-146323" src="https://mysteriousuniverse.org/wp-content/uploads/2019/08/europa-jupiter-moon-alien-life-570x421.jpg" alt="" width="570" height="421" srcset="https://mysteriousuniverse.org/wp-content/uploads/2019/08/europa-jupiter-moon-alien-life-570x421.jpg 570w, https://mysteriousuniverse.org/wp-content/uploads/2019/08/europa-jupiter-moon-alien-life-768x568.jpg 768w, https://mysteriousuniverse.org/wp-content/uploads/2019/08/europa-jupiter-moon-alien-life-640x473.jpg 640w, https://mysteriousuniverse.org/wp-content/uploads/2019/08/europa-jupiter-moon-alien-life.jpg 1920w" sizes="(max-width: 570px) 100vw, 570px" /><p id="caption-attachment-146323" class="wp-caption-text">Europa</p></div>
<p>Describing the chances for finding intelligent life at our level (we can debate the notion that we’re not so intelligent at another time) in the Milky Way as highly unlikely, Grady sees us as galactic environmentalists – protecting both our planet and any space body we set foot or probe on. Her choice of “octopus” to describe the highest level of life we might encounter may just be a backhanded reference to the movie ‘<a href="http://www.magnetreleasing.com/europareport/" target="_blank" rel="noopener noreferrer">Europa Report</a>’ in which the first mission to Europa discovers a tentacled, bioluminescent creature described as a cross between an octopus and a squid. On the other hand, many people believe that the mammal-like intelligence of octopuses is because they’re aliens on Earth. Could they be from Europa?</p>
<p>We’ll have to wait for the anticipated Jupiter Icy Moon Explorer, Europa Clipper or Europa Lander missions to find out.</p>
<p>Or, we could figure out a way to talk to an octopus.</p>
                </section> 
                <footer class="article-footer">

                  <p class="tags"><span class="tags-title">Tags</span> <a href="https://mysteriousuniverse.org/tag/bizarre/" rel="tag">Bizarre</a> <a href="https://mysteriousuniverse.org/tag/dinosaur/" rel="tag">dinosaur</a> <a href="https://mysteriousuniverse.org/tag/life-on-other-planets/" rel="tag">life on other planets</a> <a href="https://mysteriousuniverse.org/tag/octopus/" rel="tag">octopus</a> <a href="https://mysteriousuniverse.org/tag/pterosaur/" rel="tag">Pterosaur</a> <a href="https://mysteriousuniverse.org/tag/science/" rel="tag">Science</a> <a href="https://mysteriousuniverse.org/tag/space/" rel="tag">space</a> <a href="https://mysteriousuniverse.org/tag/squid/" rel="tag">squid</a></p>
                                    
                  <div class="author-meta">
                    <div class="avatar-cell">
                    <a class="avatar" href="https://mysteriousuniverse.org/author/paulseaburn/"><img width="96" height="96" src="https://mysteriousuniverse.org/wp-content/uploads/2017/06/@2x-Paul-Seaburn-125x125.png" class="avatar avatar-96 photo" alt="" srcset="https://mysteriousuniverse.org/wp-content/uploads/2017/06/@2x-Paul-Seaburn-125x125.png 125w, https://mysteriousuniverse.org/wp-content/uploads/2017/06/@2x-Paul-Seaburn-150x150.png 150w, https://mysteriousuniverse.org/wp-content/uploads/2017/06/@2x-Paul-Seaburn.png 212w" sizes="(max-width: 96px) 100vw, 96px" /></a>                    </div>

                    <div class="desc-cell">
                       <div class="desc">
                         <strong>Paul Seaburn</strong> is the editor at Mysterious Universe and its most prolific writer. He’s written for TV shows such as "The Tonight Show", "Politically Incorrect" and an award-winning children’s program. He's been published in “The New York Times" and "Huffington Post” and has co-authored numerous collections of trivia, puzzles and humor. His “<a href="http://newclevelandradio.net/follow-what-in-the-world-with-paul-seaburn/">What in the World!”</a> podcast is a fun look at the latest weird and paranormal news, strange sports stories and odd trivia. Paul likes to add a bit of humor to each MU post he crafts. After all, the mysterious doesn't always have to be serious.                       </div>
                     
                                                                         <div class="author-social">
                          You can follow Paul on 
                                                      <a href="https://twitter.com/paulseaburn"><span class="icon-twitter"></span></a>
                                                                                <span class="and">and</span> 
                                                                                <a href="https://www.facebook.com/paul.seaburn"><span class="icon-facebook2"></span></a>
                                                   </div>
                                           </div>
                    
                  </div>                    
                                    

                </footer> 
                
              </article> 
						
						
					</main>

									<div id="sidebar1" class="sidebar m-all t-all d-2of7 last-col cf" role="complementary">

					
													
							<div class="single-post-sidebar" style="display: none;">
								<div id="join_plus-3" class="widget widget_join_plus">		<div class="content">
			<div class="text">
				Join <b>Plus+</b> for $9 a month to access <b>bonus</b> <b>podcasts</b> & <b>premium</b> content!			</div>

						<div class="button">
				<!-- <a href="">Learn More</a> -->
				<a href="https://mysteriousuniverse.org/plus">Learn More</a>
			</div>
					</div>

		</div><div id="text-14" class="widget widget_text">			<div class="textwidget"><p><!-- /30438525/MysteriousUniverse/mysteriousu_sidebanner_300x250_1 --></p>
<div id='div-gpt-ad-1500210453292-5' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500210453292-5'); });
</script>
</div>
</div>
		</div><div id="recent_posts_with_thumbs-3" class="widget widget_recent_posts_with_thumbs"><h4 class="widgettitle">Recent Articles</h4>
		<ul> 	

				
				<li>
					<div class="thumb "><a href="https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/"><img width="999" height="540" src="https://mysteriousuniverse.org/wp-content/uploads/2019/03/Octopus-e1581245645989-999x540.jpg" class="attachment-article_large size-article_large wp-post-image" alt="" /></a></div>
		
					<h5><a href="https://mysteriousuniverse.org/2020/02/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa/">Scientist Claims Alien &#8220;Octopus-like Creatures&#8221; May Be Living on Jupiter&#8217;s Moon Europa</a></h5>
				</li>
				
					

				
				<li>
					<div class="thumb "><a href="https://mysteriousuniverse.org/2020/02/the-alleged-time-traveling-woman-and-her-cell-phone-10-years-later/"><img width="999" height="540" src="https://mysteriousuniverse.org/wp-content/uploads/2018/11/time-travel-next-us-president-999x540.jpg" class="attachment-article_large size-article_large wp-post-image" alt="Time traveler predicts next president" /></a></div>
		
					<h5><a href="https://mysteriousuniverse.org/2020/02/the-alleged-time-traveling-woman-and-her-cell-phone-10-years-later/">The (Alleged) Time-Traveling Woman and Her Cell-Phone: 10 Years Later</a></h5>
				</li>
				
					

				
				<li>
					<div class="thumb "><a href="https://mysteriousuniverse.org/2020/02/the-search-for-the-mysterious-golden-owl/"><img width="999" height="540" src="https://mysteriousuniverse.org/wp-content/uploads/2020/02/Golden-Owl-1-898x600-1-999x540.jpg" class="attachment-article_large size-article_large wp-post-image" alt="" /></a></div>
		
					<h5><a href="https://mysteriousuniverse.org/2020/02/the-search-for-the-mysterious-golden-owl/">The Search for the Mysterious Golden Owl</a></h5>
				</li>
				
					

				
				<li>
					<div class="thumb "><a href="https://mysteriousuniverse.org/2020/02/new-study-finds-a-pterosaur-who-didnt-like-calamari-for-a-good-reason/"><img width="999" height="540" src="https://mysteriousuniverse.org/wp-content/uploads/2019/09/Pterosaur-1-999x540.jpg" class="attachment-article_large size-article_large wp-post-image" alt="" /></a></div>
		
					<h5><a href="https://mysteriousuniverse.org/2020/02/new-study-finds-a-pterosaur-who-didnt-like-calamari-for-a-good-reason/">New Study Finds a Pterosaur Who Didn’t Like Calamari For a Good Reason</a></h5>
				</li>
				
						</ul>
		</div><div id="text-17" class="widget widget_text">			<div class="textwidget"><p><!-- /30438525/MysteriousUniverse/mysteriousu_sidebanner_300x250_2 --></p>
<div id="div-gpt-ad-1500210453292-6" style="height: 250px; width: 300px;"><script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500210453292-6'); });
</script></div>
</div>
		</div><div id="text-18" class="widget widget_text">			<div class="textwidget"><div class="not-mobile">
<div class="OUTBRAIN" data-widget-id="SB_1" data-ob-template="Admination"></div>
<p><script type="text/javascript" src="//widgets.outbrain.com/outbrain.js"></script>
</div>
</div>
		</div><div id="ai_widget-2" class="widget ai_widget ai-sticky-widget"><div class='code-block code-block-5' style=''>
<!-- /30438525/MysteriousUniverse/mysteriousu_sidebanner_300x600_sticky -->
<div id="div-gpt-ad-1500210453292-7" style="height: 600px; width: 300px;" class="ai-sticky">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500210453292-7'); });
</script>
</div></div>
</div>							</div>	

						
					
				</div>

				
				<div id="sidebar2" class="sidebar2 m-all t-all d-all cf wrap" role="complementary">

					
													
							<div class="single-post-footer" style="">
								<div id="related_posts-1" class="widget widget_related_posts"><h4 class="widgettitle">Related Articles</h4>		<!-- Related Articles -->
		<ul class="related-articles">
			
				 

				<li>
					<div class="thumb ">
						
						
													<a href="https://mysteriousuniverse.org/2016/04/600-mile-long-coral-reef-discovered-at-mouth-of-the-amazon/" style='background-image: url("https://mysteriousuniverse.org/wp-content/uploads/2016/04/amazon-643x440.jpg");'></a>
												
					</div>

					<!--h6></h6-->
					<h5><a href="https://mysteriousuniverse.org/2016/04/600-mile-long-coral-reef-discovered-at-mouth-of-the-amazon/">600-Mile Long Coral Reef Discovered at Mouth of the Amazon</a></h5>
					<p class="byline entry-meta vcard">
                       <span class="entry-author author" itemprop="author" itemscope itemptype="http://schema.org/Person"><a href="https://mysteriousuniverse.org/author/paulseaburn/">Paul Seaburn</a></span> <time class="updated entry-time" datetime="2016-04-24" itemprop="datePublished"><a href="https://mysteriousuniverse.org/2016/04/24">April 24, 2016</a></time>                    </p>

					<!-- <a href="https://mysteriousuniverse.org/2016/04/600-mile-long-coral-reef-discovered-at-mouth-of-the-amazon/" class="more">Read More</a> -->
					<!-- <p class="comments"><a href="https://mysteriousuniverse.org/2016/04/600-mile-long-coral-reef-discovered-at-mouth-of-the-amazon/#respond"><span class="dsq-postid" data-dsqidentifier="60168 http://mysteriousuniverse.org/?p=60168"><span>&nbsp;</span>0</span></a></p> -->
				</li>
			
				 

				<li>
					<div class="thumb ">
						
						
													<a href="https://mysteriousuniverse.org/2018/06/the-perfect-human-body-may-look-like-an-extraterrestrial/" style='background-image: url("https://mysteriousuniverse.org/wp-content/uploads/2018/06/dark-2971931_1920-643x440.jpg");'></a>
												
					</div>

					<!--h6></h6-->
					<h5><a href="https://mysteriousuniverse.org/2018/06/the-perfect-human-body-may-look-like-an-extraterrestrial/">The Perfect Human Body May Look Like an Extraterrestrial</a></h5>
					<p class="byline entry-meta vcard">
                       <span class="entry-author author" itemprop="author" itemscope itemptype="http://schema.org/Person"><a href="https://mysteriousuniverse.org/author/paulseaburn/">Paul Seaburn</a></span> <time class="updated entry-time" datetime="2018-06-16" itemprop="datePublished"><a href="https://mysteriousuniverse.org/2018/06/16">June 16, 2018</a></time>                    </p>

					<!-- <a href="https://mysteriousuniverse.org/2018/06/the-perfect-human-body-may-look-like-an-extraterrestrial/" class="more">Read More</a> -->
					<!-- <p class="comments"><a href="https://mysteriousuniverse.org/2018/06/the-perfect-human-body-may-look-like-an-extraterrestrial/#respond"><span class="dsq-postid" data-dsqidentifier="113363 http://mysteriousuniverse.org/?p=113363"><span>&nbsp;</span>0</span></a></p> -->
				</li>
			
				 

				<li>
					<div class="thumb ">
						
						
													<a href="https://mysteriousuniverse.org/2016/04/new-insights-on-the-link-between-lsd-and-music/" style='background-image: url("https://mysteriousuniverse.org/wp-content/uploads/2016/04/headphonens-600x440.jpg");'></a>
												
					</div>

					<!--h6></h6-->
					<h5><a href="https://mysteriousuniverse.org/2016/04/new-insights-on-the-link-between-lsd-and-music/">New Insights on the Link Between LSD and Music</a></h5>
					<p class="byline entry-meta vcard">
                       <span class="entry-author author" itemprop="author" itemscope itemptype="http://schema.org/Person"><a href="https://mysteriousuniverse.org/author/paulseaburn/">Paul Seaburn</a></span> <time class="updated entry-time" datetime="2016-04-30" itemprop="datePublished"><a href="https://mysteriousuniverse.org/2016/04/30">April 30, 2016</a></time>                    </p>

					<!-- <a href="https://mysteriousuniverse.org/2016/04/new-insights-on-the-link-between-lsd-and-music/" class="more">Read More</a> -->
					<!-- <p class="comments"><a href="https://mysteriousuniverse.org/2016/04/new-insights-on-the-link-between-lsd-and-music/#respond"><span class="dsq-postid" data-dsqidentifier="60665 http://mysteriousuniverse.org/?p=60665"><span>&nbsp;</span>0</span></a></p> -->
				</li>
			
				 

				<li>
					<div class="thumb ">
						
						
													<a href="https://mysteriousuniverse.org/2016/04/how-deep-sea-creatures-survived-the-dino-killing-asteroid/" style='background-image: url("https://mysteriousuniverse.org/wp-content/uploads/2016/04/dinosaur-meteorite_3040850b.jpg");'></a>
												
					</div>

					<!--h6></h6-->
					<h5><a href="https://mysteriousuniverse.org/2016/04/how-deep-sea-creatures-survived-the-dino-killing-asteroid/">How Deep Sea Creatures Survived the Dino-Killing Asteroid</a></h5>
					<p class="byline entry-meta vcard">
                       <span class="entry-author author" itemprop="author" itemscope itemptype="http://schema.org/Person"><a href="https://mysteriousuniverse.org/author/nschuemann/">Nancy Loyan Schuemann</a></span> <time class="updated entry-time" datetime="2016-04-20" itemprop="datePublished"><a href="https://mysteriousuniverse.org/2016/04/20">April 20, 2016</a></time>                    </p>

					<!-- <a href="https://mysteriousuniverse.org/2016/04/how-deep-sea-creatures-survived-the-dino-killing-asteroid/" class="more">Read More</a> -->
					<!-- <p class="comments"><a href="https://mysteriousuniverse.org/2016/04/how-deep-sea-creatures-survived-the-dino-killing-asteroid/#respond"><span class="dsq-postid" data-dsqidentifier="59980 http://mysteriousuniverse.org/?p=59980"><span>&nbsp;</span>0</span></a></p> -->
				</li>
					</ul>
		<!-- END Related Articles -->
		</div><div id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="OUTBRAIN" data-widget-id="AR_5" data-ob-template="Admination" ></div>
<script type="text/javascript" src="//widgets.outbrain.com/outbrain.js"></script></div></div><div id="join_plus-4" class="widget widget_join_plus">		<div class="content">
			<div class="text">
				Join <b>Plus+</b> for $9 a month to access <b>bonus</b> <b>podcasts</b> & <b>premium</b> content!			</div>

						<div class="button">
				<!-- <a href="">Learn More</a> -->
				<a href="https://mysteriousuniverse.org/plus">Learn More</a>
			</div>
					</div>

		</div>							</div>	

						
					
				</div>
				
				
					
<div id="disqus_thread"></div>

				</div>

			</div>

			<footer class="footer" role="contentinfo" itemscope itemtype="http://schema.org/WPFooter">

				<div id="inner-footer" class="wrap cf">

					<div class="block left">
						<h3>Learn More</h3>

						<nav role="navigation">
							<div class="footer-links cf"><ul id="menu-site-info" class="nav footer-nav cf"><li id="menu-item-88705" class="mu-plus-item menu-item menu-item-type-post_type menu-item-object-page menu-item-88705"><a href="https://mysteriousuniverse.org/plus/">Join MU PLUS+</a></li>
<li id="menu-item-88791" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88791"><a href="https://mysteriousuniverse.org/contact-us/">Contact Us</a></li>
<li id="menu-item-14624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14624"><a href="https://mysteriousuniverse.org/about/">About</a></li>
<li id="menu-item-88710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88710"><a href="https://mysteriousuniverse.org/faq/">FAQ</a></li>
<li id="menu-item-88714" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88714"><a href="https://mysteriousuniverse.org/advertisers/">Advertisers</a></li>
<li id="menu-item-14555" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14555"><a href="https://mysteriousuniverse.org/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-14556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14556"><a href="https://mysteriousuniverse.org/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-88719" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88719"><a href="https://mysteriousuniverse.org/mu-app-version/">MU App Version Notes</a></li>
</ul></div>						</nav>
					</div>

											<div class="socials">
							<ul>
																	<li><a href="https://www.facebook.com/mysteriousuniv" class="facebook-link" target="_blank"><span class="icon-facebook2"></span></a></li>
																									<li><a href="http://twitter.com/mysteriousuniv" class="twitter-link" target="_blank"><span class="icon-twitter"></span></a></li>
															</ul>
						</div>
						
					<div class="callus">
						<h3 class="long">Call our voicemail and leave a message</h3>
						<h3 class="short">Call our voicemail!</h3>
						<div class="call">
							<ul>
								<li><div class="voicemail">
									<span class="icon-voicemail"></span>
									<div class="title">Voicemail</div>
									<div class="id">+1 (530) 918 4070</div>
								</div></li>
								<li><div class="or">
									<div class="title">or</div>
								</div></li>
								<li><div class="skype">
									<span class="icon-skype"></span>
									<div class="title">Skype</div>
									<div class="id">MysteriousUniv</div>
								</div></li>
							</ul>
						</div>
					</div>

					<div class="buy">
						<h5>Buy the Podcast Back Catalogue</h5>
<h6><a href="https://mysterious-universe.myshopify.com/products/megapack-2008-2012"><img class="alignnone size-medium wp-image-79074" src="https://mysteriousuniverse.org/wp-content/uploads/2017/06/store_footer_mega_pack-300x169.png" alt="" width="300" height="169" /></a>The Mega Value Pack</h6>
<p>Get the MegaPack collection now for this great price.</p>
<p class="price"><span class="number">$99.00</span><a href="http://store.mysteriousuniverse.org/catalog/mega-value-pack/" class="purchase-button">Buy Now</a></p>
<p>&nbsp;</p>
					</div>

					<p class="source-org copyright">Copyright &copy; Mysterious Universe. Mysterious Universe is a property of 8th Kind Pty Ltd</p>

				</div>

			</footer>

		</div>
				  <!-- Mobile Menu -->
      <label class="overlay-menu"></label>
      <nav role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement" class="mobile-menu">
                  <ul class="user-menu nav-menu">
            <li class="nav-header"><span>Main Menu</span></li>           
            <li class="border"><a href="https://mysteriousuniverse.org/log-in" title="Login">Log In</a></li>
          </ul>
        
        <ul id="menu-mobile-menu" class="nav-menu nav"><li id="menu-item-88746" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88746"><a href="https://mysteriousuniverse.org/plus/">Join Plus+</a></li>
<li id="menu-item-88744" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88744"><a href="https://mysteriousuniverse.org/app/">Get the MU App</a></li>
<li id="menu-item-88747" class="border menu-item menu-item-type-custom menu-item-object-custom menu-item-88747"><a href="http://mysteriousuniverse.org/shop">MU Store</a></li>
<li id="menu-item-88748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88748"><a href="https://mysteriousuniverse.org/category/podcasts/">Podcasts</a></li>
<li id="menu-item-88806" class="latest menu-item menu-item-type-post_type menu-item-object-page menu-item-88806"><a href="https://mysteriousuniverse.org/latest/">Latest</a></li>
<li id="menu-item-88767" class="border categories menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-88767"><a href="#">Categories</a>
<ul class="sub-menu menu-odd  menu-depth-1">
<li class="sub-menu-item menu-item-odd menu-item-depth-1 menu-item nav-header"><span>Categories</span></li>
	<li id="menu-item-88768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88768"><a href="https://mysteriousuniverse.org/category/ancient/">Ancient Mysteries</a></li>
	<li id="menu-item-88769" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88769"><a href="https://mysteriousuniverse.org/category/bizarre/">Bizarre</a></li>
	<li id="menu-item-88770" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88770"><a href="https://mysteriousuniverse.org/category/conspiracy/">Conspiracy</a></li>
	<li id="menu-item-88771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88771"><a href="https://mysteriousuniverse.org/category/cryptozoology/">Cryptozoology</a></li>
	<li id="menu-item-88772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88772"><a href="https://mysteriousuniverse.org/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-88773" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88773"><a href="https://mysteriousuniverse.org/category/ghostshauntings/">Ghosts &#038; Hauntings</a></li>
	<li id="menu-item-88774" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88774"><a href="https://mysteriousuniverse.org/category/modernmystery/">Modern Mysteries</a></li>
	<li id="menu-item-88775" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88775"><a href="https://mysteriousuniverse.org/category/naturalworld/">Natural World</a></li>
	<li id="menu-item-88776" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88776"><a href="https://mysteriousuniverse.org/category/news/">News</a></li>
	<li id="menu-item-88777" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88777"><a href="https://mysteriousuniverse.org/category/plus-articles/">Plus+ Articles</a></li>
	<li id="menu-item-88778" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88778"><a href="https://mysteriousuniverse.org/category/plus-podcasts/">Plus+ Podcasts</a></li>
	<li id="menu-item-88779" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88779"><a href="https://mysteriousuniverse.org/category/podcasts/">Podcasts</a></li>
	<li id="menu-item-88780" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88780"><a href="https://mysteriousuniverse.org/category/psychedelics/">Psychedelics</a></li>
	<li id="menu-item-88781" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88781"><a href="https://mysteriousuniverse.org/category/scitech/">Science &#038; Technology</a></li>
	<li id="menu-item-88782" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88782"><a href="https://mysteriousuniverse.org/category/spaceastronomy/">Space &#038; Astronomy</a></li>
	<li id="menu-item-88783" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88783"><a href="https://mysteriousuniverse.org/category/spirituality/">Spirituality</a></li>
	<li id="menu-item-88784" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88784"><a href="https://mysteriousuniverse.org/category/ufo-phenomenon/">UFO Phenomenon</a></li>
	<li id="menu-item-88785" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88785"><a href="https://mysteriousuniverse.org/category/video/">Video</a></li>
</ul>
</li>
<li id="menu-item-88786" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88786"><a href="https://mysteriousuniverse.org/about/">About</a></li>
<li id="menu-item-88787" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88787"><a href="https://mysteriousuniverse.org/faq/">FAQ</a></li>
<li id="menu-item-88788" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88788"><a href="https://mysteriousuniverse.org/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-88789" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88789"><a href="https://mysteriousuniverse.org/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-88790" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88790"><a href="https://mysteriousuniverse.org/advertisers/">Advertisers</a></li>
</ul>          
      </nav>

      <label class="overlay-submenu"></label>
      <div class="mobile-header">
        <div class="menu-back-btn"></div>
        <div class="title-text"></div>
        <div class="menu-close-btn"></div>
      </div>
      			<script type="text/javascript">
				function get_stripe_vars() {
					return eval( '(' + '{"cancelmessage":"Are you sure you want to cancel your subscription?","nonceinvoices":"80c859678e","nonceinvoicedetail":"f4bef6b465","noncecoupon":"9747b2b9ed","noncecoupondetail":"e834168aeb","stripethankyouurl":"https:\/\/mysteriousuniverse.org\/register\/AWXbu0"}' +')');
				}
			</script>
			<script type="text/javascript">
jQuery(function($) {
});
</script>
<!-- Homepage Tracking --> 
<!-- /30438525/MysteriousUniverse/MysteriousU_1x1_1 -->
<div id='div-gpt-ad-1500211308409-8' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500211308409-8'); });
</script>
</div>

<!-- /30438525/MysteriousUniverse/MysteriousU_1x1_2 -->
<div id='div-gpt-ad-1500211308409-9' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500211308409-9'); });
</script>
</div>
<!-- END Homepage Tracking -->
<!-- Article Tracking -->
<!-- /30438525/MysteriousUniverse/MysteriousU_1x1_1 -->
<div id='div-gpt-ad-1500210453292-8' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500210453292-8'); });
</script>
</div>

<!-- /30438525/MysteriousUniverse/MysteriousU_1x1_2 -->
<div id='div-gpt-ad-1500210453292-9' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500210453292-9'); });
</script>
</div>
<!-- END Article Tracking --><script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"mysteriousuniverse"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"156946 https:\/\/mysteriousuniverse.org\/?p=156946","disqusShortname":"mysteriousuniverse","disqusTitle":"Scientist Claims Alien \u201cOctopus-like Creatures\u201d May Be Living on Jupiter\u2019s Moon Europa","disqusUrl":"https:\/\/mysteriousuniverse.org\/2020\/02\/scientist-claims-alien-octopus-like-creatures-may-be-living-on-jupiters-moon-europa\/","postId":"156946"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-content/themes/mysterious-universe-2/library/js/scripts.js'></script>
<script type='text/javascript' src='https://mysteriousuniverse.org/wp-includes/js/wp-embed.min.js'></script>
<script>
function ai_run_scripts(){jQuery(document).ready(function(m){var d=function(c){var d=0,h=15,k=c(document).width();c(".ai-sticky-widget").each(function(){for(var b=c(this),l=b.width(),e=!1,a=b.parent();"BODY"!=a.prop("tagName");){if(a.hasClass("theiaStickySidebar")){e=!0;break}var f=a.parent(),g=f.width();if(g>1.2*l||g>k/2)break;a=f}e||(b=a.offset().top-b.offset().top+h,0==d?("sticky"!=a.css("position")||isNaN(parseInt(a.css("top")))||a.css("top")<b)&&a.css("position",
"sticky").css("position","-webkit-sticky").css("top",b):a.theiaStickySidebar({additionalMarginTop:b,sidebarBehavior:"stick-to-top"}))})};"undefined"==typeof ai_sticky_sidebar_delay&&(ai_sticky_sidebar_delay=20);setTimeout(function(){d(jQuery)},ai_sticky_sidebar_delay)});
}function ai_load_translations(){/* <![CDATA[ */
ai_front = {"wp_ai":"5.3.2+2.6.2","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN","fallback":"FALLBACK","automatically_placed":"Automatically placed by AdSense Auto ads code"};
/* ]]> */}
function ai_wait_for_jquery(){function b(b,c){var a=document.createElement("script");a.src=b;var d=document.getElementsByTagName("head")[0],e=!1;a.onload=a.onreadystatechange=function(){e||this.readyState&&"loaded"!=this.readyState&&"complete"!=this.readyState||(e=!0,c&&c(),a.onload=a.onreadystatechange=null,d.removeChild(a))};d.appendChild(a)}window.jQuery?ai_run_scripts():(ai_jquery_waiting_counter++,4==ai_jquery_waiting_counter&&(b("https://mysteriousuniverse.org/wp-includes/js/jquery/jquery.js?ver=5.3.2",function(){b("https://mysteriousuniverse.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=5.3.2",null)}),ai_load_translations()),
30>ai_jquery_waiting_counter&&setTimeout(function(){ai_wait_for_jquery()},50))}ai_jquery_waiting_counter=0;ai_wait_for_jquery();

</script>

	</body>

</html> <!-- end of site. what a ride! -->
