<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
<head>
<meta name="apple-itunes-app" content="app-id=721204906"/>
<meta name="google-site-verification" content="8FEi3BSJzzc5JxD6PZJOoqRFYQiyF22ZBDM6tnY6rxc"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Mysterious Otherworldly Military Engagements in the Vietnam War | Mysterious Universe</title>
<link rel="pingback" href="http://mysteriousuniverse.org/xmlrpc.php"/>
<link rel="shortcut icon" href="http://mysteriousuniverse.org/wp-content/themes/mysterious-universe/images/favicon.ico"/>
<script type="text/javascript">
	window.google_analytics_uacct = "UA-10374297-1";
	</script>
<style type="text/css">#fancybox-close{right:-15px;top:-15px}div#fancybox-content{border-color:#FFFFFF}div#fancybox-outer{background-color:#FFFFFF}</style>
 
<link rel="author" href="https://plus.google.com/+mysteriousuniverse/"/>
<meta name="description" content="One aspect of the Vietnam War that has long slipped under the radar of the mainstream consciousness is that amongst the fighting and violence the conflict was"/>
<meta name="keywords" content="alien attack,aliens,bizarre,conspiracy,modern mysteries,ufo attack,ufo in war zone,ufos,unexplained phenomena,unsolved mystery,vietnam war,war,war mysteries,ufo phenomenon"/>
<link rel="canonical" href="http://mysteriousuniverse.org/2017/02/mysterious-otherworldly-military-engagements-in-the-vietnam-war/"/>
<meta property="og:title" content="Mysterious Otherworldly Military Engagements in the Vietnam War | Mysterious Universe"/>
<meta property="og:type" content="blog"/>
<meta property="og:url" content="http://mysteriousuniverse.org/2017/02/mysterious-otherworldly-military-engagements-in-the-vietnam-war/"/>
<meta property="og:image" content="http://mysteriousuniverse.org/wp-content/uploads/2017/02/rendlesham_forest_ufo_incident01-570x384.jpg"/>
<meta property="og:site_name" content="Mysterious Universe"/>
<meta property="fb:admins" content="508967392"/>
<meta property="og:description" content="One aspect of the Vietnam War that has long slipped under the radar of the mainstream consciousness is that amongst the fighting and violence the conflict was absolutely rife with reports of strange things in the sky that defied conventional explanation. Even less known still are numerous bizarre reports of actual confrontations between military forces and other forces that seem to have been, shall we say, not from around here. Reading like something out of a science fiction story or alien invasion flick, these frightening accounts of violent encounters with UFOs during the Vietnam War suggest that it was not only the North Vietnamese forces that were the enemy, but also decidedly more otherworldly adversaries as well. By all accounts it seems that troops in the Vietnam War were absolutely plagued by UFO activity, and some of the most spectacular reports of alien encounters during the Vietnam War have to do with actual military engagements with UFOs. One such incident allegedly"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:title" content="Mysterious Otherworldly Military Engagements in the Vietnam War | Mysterious Universe"/>
<meta name="twitter:description" content="One aspect of the Vietnam War that has long slipped under the radar of the mainstream consciousness is that amongst the fighting and violence the conflict was absolutely rife with reports of strange things in the sky that defied conventional explanation. Even less known still are numerous bizarre reports of actual confrontations between military forces and other forces that seem to have been, shall we say, not from around here. Reading like something out of a science fiction story or alien invasion flick, these frightening accounts of violent encounters with UFOs during the Vietnam War suggest that it was not only the North Vietnamese forces that were the enemy, but also decidedly more otherworldly adversaries as well. By all accounts it seems that troops in the Vietnam War were absolutely plagued by UFO activity, and some of the most spectacular reports of alien encounters during the Vietnam War have to do with actual military engagements with UFOs. One such incident allegedly"/>
<meta name="twitter:image" content="http://mysteriousuniverse.org/wp-content/uploads/2017/02/rendlesham_forest_ufo_incident01-570x384.jpg"/>
 
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Mysterious Universe &raquo; Feed" href="http://mysteriousuniverse.org/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Mysterious Universe &raquo; Comments Feed" href="http://mysteriousuniverse.org/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Mysterious Universe &raquo; Mysterious Otherworldly Military Engagements in the Vietnam War Comments Feed" href="http://mysteriousuniverse.org/2017/02/mysterious-otherworldly-military-engagements-in-the-vietnam-war/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/mysteriousuniverse.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<style type="text/css">.powerpress_player .wp-audio-shortcode{max-width:570px;}</style>
<link rel='stylesheet' id='google-font-open-sans-css' href='http://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700italic%2C700%2C400italic%2C600italic%2C600&#038;ver=1.0' type='text/css' media='all'/>
<link rel='stylesheet' id='google-font-exo-css' href='http://fonts.googleapis.com/css?family=Exo%3A400%2C500italic%2C500%2C400italic%2C700italic%2C700%2C200italic%2C200%2C300italic%2C300&#038;ver=1.0' type='text/css' media='all'/>
 
<script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-10374297-1']);
	_gaq.push(['_gat._forceSSL']);
	_gaq.push(['_trackPageview']);

	(function () {
		var ga = document.createElement('script');
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(ga, s);
	})();

</script>
 
<script type='text/javascript' src='http://mysteriousuniverse.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://mysteriousuniverse.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://mysteriousuniverse.org/wp-content/plugins/fancybox-for-wordpress/fancybox/jquery.fancybox.js?ver=1.3.8'></script>
<script type='text/javascript' src='http://mysteriousuniverse.org/wp-content/themes/mysterious-universe/js/jquery.flexslider-min.js?ver=2.1'></script>
<script type='text/javascript' src='http://mysteriousuniverse.org/wp-content/themes/mysterious-universe/js/functions.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='http://mysteriousuniverse.org/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://mysteriousuniverse.org/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://mysteriousuniverse.org/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.7.2"/>
<link rel='shortlink' href='http://mysteriousuniverse.org/?p=79731'/>
<link rel="alternate" type="application/json+oembed" href="http://mysteriousuniverse.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmysteriousuniverse.org%2F2017%2F02%2Fmysterious-otherworldly-military-engagements-in-the-vietnam-war%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://mysteriousuniverse.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmysteriousuniverse.org%2F2017%2F02%2Fmysterious-otherworldly-military-engagements-in-the-vietnam-war%2F&#038;format=xml"/>
 
<script type="text/javascript">
jQuery(function(){

jQuery.fn.getTitle = function() { // Copy the title of every IMG tag and add it to its parent A so that fancybox can show titles
	var arr = jQuery("a.fancybox");
	jQuery.each(arr, function() {
		var title = jQuery(this).children("img").attr("title");
		jQuery(this).attr('title',title);
	})
}

// Supported file extensions
var thumbnails = jQuery("a:has(img)").not(".nolightbox").filter( function() { return /\.(jpe?g|png|gif|bmp)$/i.test(jQuery(this).attr('href')) });

thumbnails.addClass("fancybox").attr("rel","fancybox").getTitle();
jQuery("a.fancybox").fancybox({
	'cyclic': false,
	'autoScale': true,
	'padding': 0,
	'opacity': true,
	'speedIn': 500,
	'speedOut': 500,
	'changeSpeed': 300,
	'overlayShow': true,
	'overlayOpacity': "0.6",
	'overlayColor': "#000000",
	'titleShow': true,
	'titlePosition': 'float',
	'enableEscapeButton': true,
	'showCloseButton': true,
	'showNavArrows': true,
	'hideOnOverlayClick': true,
	'hideOnContentClick': false,
	'width': 560,
	'height': 340,
	'transitionIn': "elastic",
	'transitionOut': "elastic",
	'centerOnScroll': true
});


})
</script>
 
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
 
<noscript><link rel="stylesheet" type="text/css" href="http://mysteriousuniverse.org/wp-content/plugins/q-and-a/css/q-a-plus-noscript.css?ver=1.0.6.2"/></noscript>  
<style type='text/css'>.WishListMember_Widget{}.WishListMember_LoginMergeCode{}</style> <!--[if lte IE 8]>
		<link rel="stylesheet" href="http://mysteriousuniverse.org/wp-content/themes/mysterious-universe/ie.css" type="text/css" media="all" />
	<![endif]-->
 
<script type="text/javascript">
(function(){
  var bsa = document.createElement('script');
     bsa.type = 'text/javascript';
     bsa.async = true;
     bsa.src = 'http://s3.buysellads.com/ac/bsa.js';
  (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
})();
</script>
  <link rel='stylesheet' id='combine-css' href='http://mysteriousuniverse.org/wp-content/plugins/combine-css/css.php?token=14e9b2f6fa738a2d969998ba3d1136cf&#038;ver=2' type='text/css' media='all'/>
</head>
<body class="post-template-default single single-post postid-79731 single-format-standard ua-windows">
 
<div id="wrapper">
 
<div id="top-bar">
<div class="shell">
<p class="left">
MU<a href="/plus" class="pluse-button">PLUS+</a>
<span class="sep">&nbsp;</span>
<strong>Join Plus+ and get exclusive shows and extensions!</strong> Subscribe Today!
<a href="/plus" class="learn-button">LEARN MORE</a>
<span class="sep">&nbsp;</span>
</p>
<ul id="menu-top-bar-menu" class="right top-nav-menu"><li id="menu-item-14557" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14557"><a href="http://mysteriousuniverse.org/plus/">Plus+</a></li>
<li id="menu-item-14558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14558"><a href="/wp-login.php">LOGIN</a></li>
</ul> <div class="cl">&nbsp;</div>
</div>
<a href="#" class="close">Close</a>
</div>
 
 
<div id="header">
 
<div class="shell">
<h1 id="logo"><a href="http://mysteriousuniverse.org/">Mysterious Universe</a></h1>
 
<div id="navigation">
<ul id="menu-main-menu" class="menu"><li id="menu-item-14547" class="home-link menu-item menu-item-type-custom menu-item-object-custom menu-item-14547"><a href="/">Home</a></li>
<li id="menu-item-14548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14548"><a href="http://mysteriousuniverse.org/category/podcasts/">Podcasts</a></li>
<li id="menu-item-14549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14549"><a href="http://mysteriousuniverse.org/plus/">Plus+</a></li>
<li id="menu-item-14756" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14756"><a href="http://mysteriousuniverse.org/app/">App</a></li>
<li id="menu-item-19875" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19875"><a href="http://store.mysteriousuniverse.org">Store</a></li>
<li id="menu-item-14551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14551"><a href="http://mysteriousuniverse.org/contact-us/">Contact Us</a></li>
<li id="menu-item-19089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19089"><a href="http://mysteriousuniverse.org/faq/">FAQ</a></li>
<li id="menu-item-14552" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14552"><a href="http://mysteriousuniverse.org/dashboard/">Dashboard</a></li>
</ul> </div>
 
<form class="search-container" method="get" action="http://mysteriousuniverse.org/">
<div class="search-field">
<input type="text" value="" name="s"/>
</div>
<input type="submit" value="" class="search-button"/>
</form>
<div class="cl">&nbsp;</div>
</div>
 
</div>
 
 
<div id="main">
 
<div class="shell">
 
<div id="bsap_1296298" class="bsarocks bsap_a3d581099f492b46baa9b3edabd503b9" style="text-align:center;overflow: hidden;margin:0 auto 10px auto;width: 728px;"></div>
<p class="ad small aligncenter"><a href="http://bsa.ly/bn8" style="color:white;">Advertise here now!</a></p>
 
 
<div id="content">
 
<div class="container">
<div class="top">&nbsp;</div>
<div class="entry">
 
<div class="post">
<div class="top">&nbsp;</div>
<img width="570" height="306" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/rendlesham_forest_ufo_incident01-570x306.jpg" class="img post-img wp-post-image" alt=""/> <div class="inner">
<h2>Mysterious Otherworldly Military Engagements in the Vietnam War</h2>
<div class="details">
<ul>
<li class="comments-link">
<a href="http://mysteriousuniverse.org/2017/02/mysterious-otherworldly-military-engagements-in-the-vietnam-war/#respond">
 
<span class="dsq-postid" data-dsqidentifier="79731 http://mysteriousuniverse.org/?p=79731"><strong>0</strong> Comments</span> </a>
</li>
<li><a href="http://mysteriousuniverse.org/2017/02/10/"><span class="icon-3">&nbsp;</span>February 10, 2017</a></li>
<li><a rel="author" href="http://mysteriousuniverse.org/author/brentswancer/"><span class="icon-4">&nbsp;</span>Brent Swancer</a></li>
</ul>
<div class="cl">&nbsp;</div>
</div>
<p>One aspect of the Vietnam War that has long slipped under the radar of the mainstream consciousness is that amongst the fighting and violence the conflict was absolutely rife with reports of strange things in the sky that defied conventional explanation. Even less known still are numerous bizarre reports of actual confrontations between military forces and other forces that seem to have been, shall we say, not from around here. Reading like something out of a science fiction story or alien invasion flick, these frightening accounts of violent encounters with UFOs during the Vietnam War suggest that it was not only the North Vietnamese forces that were the enemy, but also decidedly more otherworldly adversaries as well.</p>
<p>By all accounts it seems that troops in the Vietnam War were absolutely plagued by UFO activity, and some of the most spectacular reports of alien encounters during the Vietnam War have to do with actual military engagements with UFOs. One such incident allegedly occurred on June 15, 1968, along the demilitarized zone (DMZ) between North and South Vietnam, where a patrol boat known as PCF-12, commanded by a Lieutenant Pete Snyder, was on a routine night patrol near Cua Viet. At 12:30AM, PCF-12 reportedly received a frantic distress call from another patrol boat in the vicinity, PCF-19, claiming that they were being attacked by unidentified lights they were calling “enemy helicopters,” which seemed odd because the North Vietnamese enemy were not known to utilize combat helicopters at the time.</p>
<p><img class="aligncenter size-large wp-image-80033" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/rendelsham-forest-570x380.jpg" alt="" width="570" height="380" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/rendelsham-forest-570x380.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/rendelsham-forest-300x200.jpg 300w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/rendelsham-forest-768x513.jpg 768w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/rendelsham-forest.jpg 1200w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>Snyder ordered the PCF-12 to head for PCF-19’s position to offer assistance, and they as they closed in reported spotting in the sky two circular bright lights immersed in a “strange glow” hovering over PCF-19’s position. As they approached, one of the strange lights reportedly emitted a bright flash of light, after which PCF-19 exploded in a cascade of water and flying debris. Directly after the destruction of PCF-19, the two enigmatic lights were described as rapidly accelerating away towards the sea as PCF-12 scouted the area for any possible survivors of the carnage they had just witnessed. Two wounded men were found and recalled that the two UFOs had been trailing them for miles along the river. The survivors then claimed that they had decided to fire upon the threatening, mysterious objects, and that was when one of them had issued a piercing blast of light to obliterate the boat. At first it was thought by officials that the PCF-12 had been the victim of an enemy missile fired from shore, but a later AP dispatch from Saigon would quote a military spokesman as having attributed the loss of PCF-19 to an “unidentified object,” and not enemy coastal batteries or missiles.</p>
<p>The PCF-12 continued its patrol up the river and were soon approached by the same two unidentified lights, which took up positions hovering on the port and starboard sides around 300 yards away and 100 feet above the water. PCF-12 called in to headquarters to try and get an idea of what they were dealing with, but were met with the response that there were no aircraft in the area at the time. Realizing that these craft were not friendly, Snyder ordered his men to open fire on the lights, which apparently did little to faze or even slow them down, and PCF-12 began to retreat at full speed as the two mysterious aircraft tailed and stalked them, flickering in the night the whole time. Second engine man Jim Steffes would later claim that he got a good look at the craft and described them as having “a rounded front like an observation helo,” and what looked like “two crewman sitting side by side.”</p>
<p><img class="aligncenter size-large wp-image-80049" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/when-ufo-kill-vietnam-us-soldiers-1960-800x445-570x390.jpg" alt="" width="570" height="390" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/when-ufo-kill-vietnam-us-soldiers-1960-800x445.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/when-ufo-kill-vietnam-us-soldiers-1960-800x445-300x205.jpg 300w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/when-ufo-kill-vietnam-us-soldiers-1960-800x445-444x305.jpg 444w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>Strangely, although no weapons could be seen mounted on the unidentified aircraft, PCF-12 nevertheless found itself being fired upon. Steffes remembered seeing tracer rounds piercing up into the night from the nearby base Point Dume, with their targets being what he said were other far-off blinking circular lights whizzing about in the sky above. Eventually, a group of Phantom F4 fighter jets arrived to converge upon and chase off the strange lights that were plaguing PCF-12 out to sea, leaving the crew to wonder what in the hell had just happened.</p>
<p>At roughly the same time, another very strange incident was unfolding out in the South China Sea with an Allied ship of the Royal Australian Navy, the <em>HMAS Hobart</em>, which was patrolling near Tiger Island, about 20kms off Cap Lay and reported sighting up to 30 unidentified slow-moving lights hovering in the night sky near their ship, which were at first thought to be Russian-built M-14 &#8216;Hound&#8217; helicopters, but upon closer inspection could see they were not. US 7th Air Force Phantom fighter-bombers were sent to engage, supported by generous anti-aircraft fire from the ground. The lights flew out to sea as they were pursued by the fighters, which fired upon them mercilessly along with several other military ships in the area, which unfortunately contributed to the friendly fire incident in which a U.S. swift boat was sunk by missiles, killing 5 of the 7 crew.</p>
<p><img class="aligncenter size-large wp-image-80034" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/NUJ8000A-570x428.jpg" alt="" width="570" height="428" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/NUJ8000A.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/NUJ8000A-300x225.jpg 300w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>The <em>HMAS Hobart</em> was prepped for battle when the radar room detected an incoming unidentified aircraft coming in fast with no identification number to mark it as friend or foe. Word soon came in that the craft was “friendly,” but it was then that a missile struck the ship to kill one and injure two others, followed by a barrage of two more missiles. Whatever the craft was swiftly fled the scene before it could be shot down. In the meantime, F4 jets scrambled about firing upon the lights, supported by a hail of anti-aircraft fire from the ground, with attempts to communicate with whoever was onboard the mystery craft going unanswered. Eventually, the lights floated off and the fighter pilots were ordered back to base. The following morning, a complete search of the area turned up not a single shred of wreckage of an enemy helicopter, or any other aircraft for that matter, despite the intense fighting that had occurred. The complete and utter lack of any wreckage of any aircraft was baffling considering that they had come under such resistance and so much concerted, relentless fire. The <em>Royal Australian Navy News</em> would later confirm:</p>
<blockquote><p>No physical evidence of helicopters destroyed has been discovered in the area of activity nor has extensive reconnaissance produced any evidence of enemy helicopter operations in or near the DMZ.</p></blockquote>
<p>There was little confidence among the men engaged in the incident that the aggressors had been “enemy helicopters” as was at first claimed. After all, if that were the case they should have been decimated by the potent retaliatory force displayed upon their arrival and attacks. There was also no trace whatsoever of helicopters at the time in the area and no wreckage. A skipper aboard the <em>Hobart</em> during the baffling engagement would later claim that it was certainly not enemy helicopters, expressing his doubt of such a theory by saying:</p>
<blockquote><p>Neither before nor after the incident &#8230; was there any report by any of the ships of a helicopter being there [around Tiger Island]. Now having said that, the captain of one of the American ships told me later at Subic Bay that he thought there were helicopters there, but the fact is he didn&#8217;t report, and if he believed there was a helicopter &#8230; it was his duty to report it at the time, but there was no report.</p></blockquote>
<p><img class="aligncenter size-large wp-image-80050" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/ScalarWeatherWars-570x401.jpg" alt="" width="570" height="401" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/ScalarWeatherWars.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/ScalarWeatherWars-300x211.jpg 300w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/ScalarWeatherWars-164x116.jpg 164w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>Whatever the lights were that caused so much chaos continued to be sighted sporadically for months afterwards along the DMZ, furtively skirting around the area and baffling those who saw them. They were often sighted by radar roaming up and down the coast, and apparently no one could quite figure out what they were. They appeared on radar to be low, slow moving objects just like helicopters, but often there would be no visible confirmation or they would not look at all like helicopters, they were prone to just disappearing, and jets scrambled to intercept the objects would arrive to find nothing there. Troops on the ground would sometimes witness the lights appear and disappear out of nowhere, and in one such case American artillerymen reported seeing a group of mysterious lights along the Ben Hai River, but when they had opened fire on them the objects had suddenly vanished as if they had never been there at all. At no point did anyone report seeing an actual helicopter, and the strange objects were always described as moving lights, often hovering erratically or moving in sudden bursts of speed inconsistent with a helicopter.</p>
<p>The origin of the strange lights remains unknown to this day. There were theories at the time that somehow a misreading of radar signals had occurred, which had then made other friendly vessels appear to be slow moving flying blips, or that the North Vietnamese had more helicopter power than had been previously assumed. In the end the official explanation was that it was all due to atmospheric disturbances or possible enemy helicopter activity, coupled with panicked friendly fire, and there have also been theories that it was all due to bird flocks or even insect swarms, but does any of this really match up to what occurred? Would trained Navy and fighter jet personnel go to engage such phenomena, and what hit the <em>Hobart</em>? Indeed what attacked the PCF 12 and 19 at precisely the same time? If there were enemy helicopters involved where was all the wreckage, why were they never successfully shot down, and wouldn’t these trained men know helicopters when they saw them? It is also strange that an enemy helicopter would so brazenly venture over the heavily defended DMZ, and it would be strange that they should fly around with their lights on all of the time for hours on end. In the case of the <em>Hobart</em> it seems obvious that this was some sort of concerted attack, but by who or what remains open to debate and speculation.</p>
<p>It is interesting that these reports make mention of “enemy helicopters,” as this was a term used so often to describe any unidentified lights in the sky in Vietnam that it became sort of a code word for “UFO,” regardless of any relation the object had to an actual helicopter, becoming sort of a catch-all phrase for anything weird in the sky. The fact that the Viet Cong were not known to use helicopters made it a perfect way to explain discreetly when men were seeing something in the sky that shouldn’t be there. On October 16, 1973, the USAF Chief of Staff, General George S. Brown, gave a press conference in Illinois where he addressed this terminology to some extent when asked about UFOs in Vietnam, saying:</p>
<blockquote><p>I don’t know whether this story has ever been told or not. They weren’t called UFOs. They were called enemy helicopters. And they were only seen at night and they were only seen in certain places. They were seen up around the DMZ [demilitarized zone] in the early summer of ’68. And this resulted in quite a little battle. And in the course of this, an Australian destroyer took a hit and we never found any enemy, we only found ourselves when this had all been sorted out. And this caused some shooting there, and there was no enemy at all involved but we always reacted. Always after dark.</p></blockquote>
<p><img class="aligncenter size-large wp-image-80037" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/14-getty-ufo-in-forest-sharp-570x382.jpg" alt="" width="570" height="382" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/14-getty-ufo-in-forest-sharp.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/14-getty-ufo-in-forest-sharp-300x201.jpg 300w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>Another comment on the matter was made by a patrol boat captain by the name of Bill Cooper, who served in Vietnam from 1967 to 1969. During a UFO conference in Los Angeles in 1989, Cooper would say of his own experiences:</p>
<blockquote><p>After about five months I was sent up north to the DMZ, to a place called Qua Vieaf [perhaps Qua Viet] on the Tacan [sic] river &#8230;. It was while there that I discovered that there was a tremendous amount of UFO and alien activity in Vietnam. It was always reported in official messages as &#8216;enemy helicopters&#8217;. Now any of you who know anything about the Vietnam war know that the North Vietnamese did not have any helicopters especially after our first couple of air raids into North Vietnam [during 1965]. Even if they had, they would not have been so foolish as to bring them over the DMZ, because that would have ensured their demise.</p></blockquote>
<p>Another American ship which was not directly attacked, but nevertheless allegedly had a very intimidating and threatening encounter with an Unidentified Underwater Submersible, or USO. In 1974 the ammunitions ship the <em>USS Kilauea</em> was operating in the Indian Ocean along with a destroyer and a carrier, and the witness claims that one evening at around 9PM he had been on deck with two friends looking up at the brilliant array of stars in the night sky. Their attention was drawn to the eerie beauty of the shifting light trails formed by phosphorus algae in the wake of the ship in formation in front of them, yet as they watched this light display of nature something else began glowing in the depths, becoming brighter and brighter until it became a blinding orange/yellow ball just under the surface. The mysterious blazing orb then spectacularly burst forth from the water to arch right over the top of the destroyer, just missing smashing into it, before crashing back into the ocean on the other side and sinking back into the dark depths. The witness would say of the puzzling, frightening incident:</p>
<blockquote><p>We all just stared at each other with our mouths open.  We could not believe what we saw, but I asked friends of mine who were on watch on the bridge if they saw it and they all did.  There was nothing ever reported that I know of though and we just quit talking about it.  I bet the destroyer got a good look at it.  It went right over the bridge of that ship and it was big.  Maybe 150 to 200 feet in diameter.  That was my big encounter.</p></blockquote>
<p>Aircraft also seem to have had their share of engagements with UFOs during the Vietnam War. One rather dramatic account from 1974 begins in the air and escalates into a full-on battle on the ground. The incident allegedly began when two F-4 fighter craft purportedly engaged a slow, unidentified object in the sky, setting off a tense dogfight which saw the UFO shot out of the air to go crashing down into the middle of a heated firefight between a force of Viet Cong (NVA) and some American M-60 tanks. With the arrival of the strange craft plummeting from the heavens and plowing into the ground in their midst, the battle went silent for a time until the NVA decided to fire a rocket propelled grenade at the crippled UFO.</p>
<p><img class="aligncenter size-large wp-image-80052" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/ufo_55469-1920x12001-570x386.jpg" alt="" width="570" height="386" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/ufo_55469-1920x12001.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/ufo_55469-1920x12001-300x203.jpg 300w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>This grenade seemed to have no effect at all, and allegedly the UFO fired back with some sort of heat weapon before the tanks joined in to begin pummeling the craft with 90mm shells until it was a smoking ruin. In the meantime, the Viet Cong, perhaps sensing that things were getting a bit too weird for their liking, hastily retreated into the jungle. The report adds that within the wreckage of the craft were found several alien bodies, along with one that was apparently seriously injured but alive, although no description is given of what they looked like. The panicked commander, faced with a crashed UFO, alien bodies, and a field of groaning men injured from the previous fight with the NVA, then purportedly called in for assistance, after which a helicopter was sent, but when it arrived the men were told that it had come only to take the alien corpses rather than the wounded soldiers. The infuriated commander then apparently shot the surviving alien and threatened to further destroy the ship with his tanks before having his request to tend to the wounded first honored. It is hard to know how much truth this fantastic account has, but it is certainly rather interesting.</p>
<p>Jets also were involved with what seems to be another dogfight with UFOs at Dong Ha base, where <em>Newsweek</em> correspondent Robert Stokes happened to be at the time to witness the whole event. According to Stokes’ report, 13 sets of “yellowish white lights” appeared over the nearby Ben Hai River, after which jets were sent to intercept. One of the fighter pilots apparently managed to shoot one of the lights out of the sky. Strangely, when reconnaissance planes were scrambled to investigate the crash site only a charred, burned out spot on the ground could be seen, with no discernible wreckage at all.</p>
<p>In another account, in the early 1970s an American B-52 bomber went down over Laos under decidedly mysterious circumstances, with some last communications from the downed plane making frantic claims that they were under attack from a UFO which looked like a “large light.” A Green Beret Captain named William English was reportedly assigned to a special forces investigative team sent to go in and try to uncover what had happened to the B-52, and they were able to locate the plane in the jungle. Oddly, the aircraft was found to be fully intact and sitting on the jungle floor as if carefully placed there, with no trail of levelled vegetation to indicate a crash landing. An inspection of the hull showed no signs of external damage from a crash or indications of being hit by weapons. The only damage that could be found was discovered on the bottom of the plane, as if it had been simply dropped there from some height.</p>
<p><img class="aligncenter size-large wp-image-80041" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/3-b52_000003231551_Small-570x397.jpg" alt="" width="570" height="397" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/3-b52_000003231551_Small.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/3-b52_000003231551_Small-300x209.jpg 300w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>As weird as this all was, things would get stranger still when the cockpit was pried open. The entire crew of the plane was allegedly found still strapped into their seatbelts and had been disfigured and mutilated somehow, although the report is not clear on in just what way. Other than this, the rest of the cockpit was supposedly completely pristine, undamaged, and in working order. What happened to this B-52? Is even any truth behind this strange tale at all? It is hard to say.</p>
<p>Indeed it seems that aircraft during the Vietnam War were often threatened by unidentified flying objects, which seemed to often buzz and almost seem to be toying with military aircraft. In most cases, these strange objects would be gone before the targeted fighter could even have a chance to respond. A former US intelligence officer based in Vietnam by the name of George Filer has claimed that during his time in the country he was tasked with dealing with a wide range of such aerial encounters that defied explanation and engagements between military aircraft and UFOs. Filer would say of these incidents:</p>
<blockquote><p>You’d have an aircraft flying along, doing around 500 knots and a UFO comes alongside and does some barrel rolls around the aircraft and then flies off at three times the speed of one of the fastest jets we have in the Air Force. So, obviously, it has a technology far in advance of anything we have.</p></blockquote>
<p>Troops on the ground had some rather strange encounters as well. One particularly bizarre incident occurred in 1970, at Lone-Jon Island, where a 5-man team of soldiers claimed that they were being hunted by bright lights measuring a mere 4 inches by 4 inches in size. These lights were described as disc-shaped and having what were called “black eyes,” and they were said to be capable of great feats of maneuverability, darting, zig-zagging, and hovering all over the place. The team claimed that when they fired upon the objects they would shift color to an angry glowing red, with the black eye part morphing into a bright green. These intimidating, menacing lights apparently stalked and attacked the team during both daylight and nighttime hours over a period of 5 days, often coming shockingly close, to within 5 feet of the team’s position. One of the men supposedly took several photos of the bizarre incident.</p>
<p><img class="aligncenter size-large wp-image-80051" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/Bengal-Swamps-e1481010296803-570x400.jpg" alt="" width="570" height="400" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/Bengal-Swamps-e1481010296803.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/Bengal-Swamps-e1481010296803-300x211.jpg 300w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/Bengal-Swamps-e1481010296803-164x116.jpg 164w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>When the men got back from their harrowing ordeal and were debriefed they told of what had happened to them and were reportedly told to forget about it. Their equipment was also searched and some of it confiscated, including the pictures that had been taken. People were brought in to interview them extensively on what they had seen, and although it was unclear who they were, at least one of the men was convinced that they were CIA. Even odder still is that a few months later some American personnel allegedly showed up at the homes of the soldiers’ parents asking about any photographic materials that may have been sent to them. The whole thing adds the layer of a sinister cover-up to the already rather scary events depicted by the report.</p>
<p>American forces were certainly not the only ones apparently dealing with hostilities with UFOs. In the summer of 1968, a Ranger recon unit was operating along the DMZ in an area that what was referred to the “North Country” in the early morning hours. The team was wary, as it had already been established that an enemy Viet Cong unit was positioned on the other side of the hill, so the enemy could have been anywhere creeping about in the jungle around them. At approximately 2AM, the team claimed that a bright, fluorescent blue light could be seen closing in on their position, and that the strange, unidentified object stopped to hover momentarily around a quarter of a mile away before moving towards the baffled unit once again. The entire time the flying object was said to be completely silent.</p>
<p>As the recon unit struggled to comprehend this bizarre sight that they were seeing, the NVA on the other side of the hill, after presumably gawking at the sight as well, did what humans do and reportedly began firing on the light in full force. The night lit up with tracer rounds blazing skyward towards the strange object floating there and it must have been quite a haunting, mesmerizing sight. For a few moments the object did not react, merely absorbing the assault without showing any sign of distress or damage. Indeed, it seemed to be completely unfazed by the barrage of bullets raging at it. Then, it was claimed that a blindingly bright beam of light lashed forth from the object and the NVA machine gun fire abruptly stopped to send the jungle into a sudden silence so profound that it was jarring, the instant quiet almost deafening in the wake of the cacophony that had exploded through the air just moments before. The light in the sky then reportedly cruised off in complete silence to leave nothing but the droning sounds of the nighttime jungle behind.</p>
<p><img class="aligncenter size-large wp-image-80042" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/sshot4cb6d189f0801-570x428.jpg" alt="" width="570" height="428" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/sshot4cb6d189f0801.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/sshot4cb6d189f0801-300x225.jpg 300w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>The next morning, the recon team decided to make their way to the NVA camp to see what had happened, sensing that they were going to find something weird at the very least and they would not be disappointed. They found the enemy camp to be seemingly abandoned, and strewn about were 12.7MM machine guns and other assorted firearms that looked as if they had been partially melted by a relentless scorching heat. A closer inspection of the camp turned up what appeared to be piles of ashes and bits of what could have been charred bones scattered about. The leader of the team apparently took pictures of the scene, which he would later include in his report of the spooky incident. Shortly after, he went to rejoin his unit but was told that he had been reassigned to another team. When he asked about what had become of his report and the photos he was allegedly told that no such report existed, and that if he were to continue pressing the matter he could face prison time. Other members of the team were purportedly similarly intimidated with similar threats.</p>
<p>Another incident involving the NVA was reported in the <em>State Journal</em> in Lansing, Michigan on Sept. 29, 1972, in a piece entitled <em>What Was UFO Over Hanoi? </em>The report claimed that a luminous orange spherical UFO had appeared at a high altitude above Hanoi on a clear day, and then hovered in a stationary position. North Vietnamese air defenses had then almost immediately fired upon it with three consecutive surface-to-air missiles, but these either were either unable to reach it or unable to harm it, although after the missiles were fired it was reported that the UFO diminished somewhat in intensity, becoming “less bright” than it had been before. Nevertheless it reportedly continued to hover over the city for a full one hour and 20 minutes before leaving. In a similar incident reported by the Russian publication <em>Aura-Z</em>, another UFO was supposedly seen over Hanoi and was also fired upon by missiles, which apparently did hit it but had no effect. In this case, the UFO is claimed to have fired a “fine, needle-like, light blue ray” at the defense batteries, completely destroying them and allegedly killing around 200 personnel. This particular spectacular report has been suspected of being a hoax, but it is intriguing nonetheless.</p>
<p>In some cases these strange objects in the sides have apparently been attacked by both sides of the Vietnam conflict at the same time. One amazing such account was published in <em>The News World</em> in a 1982 article entitled &#8220;<em>Staten Is. researcher inspired by encounter in Vietnam War</em>.&#8221; The witness was a soldier by the name of Pete Mazzola, who was stationed in Vietnam from 1965 to 1970, and claimed that he had already seen plenty of unidentified lights in the sky during his tour even before the frightening incident that would change his life forever and truly convince him that UFOs were real.</p>
<p><img class="aligncenter size-large wp-image-80043" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/UFO_Attacks_Earth_5000_Years_Ago_Documented__145962-570x384.jpg" alt="" width="570" height="384" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/UFO_Attacks_Earth_5000_Years_Ago_Documented__145962.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/UFO_Attacks_Earth_5000_Years_Ago_Documented__145962-300x202.jpg 300w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>According to Mazzola, in 1967 he had been a young soldier serving in a forward observation patrol that was tasked with radioing in the coordinates of enemy positions to US Navy ships waiting in the nearby South China Sea, which would then bombard them from the water. During their mission Mazzola’ patrol found itself under attack by an enemy unit and took cover in a patch of thick, tall grass. As they cowered there, flinching from the staccato gunfire and trying to figure out what to do, they were met with the bizarre sight of several bright objects rising up into the air over the trees. He would say of this strange sight:</p>
<blockquote><p>I couldn’t believe what I saw. The other guys saw it too but afterwards were too shocked to talk much about it except to say, ‘What the hell was that?’</p></blockquote>
<p>The lights proceeded to soar up over the rice paddies and palm trees, and as they did so were suddenly attacked by incoming shells from the American ships to the south, the thunderous explosions deafening to the terrified squad on the ground. Moments later, more shells and missiles began to bombard the mysterious lights, this time from NVA positions in the north, and it seemed as if both sides of the war had momentarily forgotten their differences to focus their booming violence on these mysterious, unearthly objects. Although shell after shell whizzed through the air towards the enigmatic lights, none of them appeared to actually meet their target, always exploding before making contact to leave a puff of black smoke hanging in the air well short of their quarry. Throughout it all, the objects were described by Mazzola as being quite calm, hovering “silently, gracefully,” until around 5 minutes into the onslaught, when they apparently had had enough and shot up into the sky in unison with blinding speed.</p>
<p>Mazzola would later speculate that the UFOs had been employing some sort of device that had somehow prevented the missiles and artillery shells from reaching them. The strange incident had such a profound effect on him that the once skeptical Mazzola, who in later years became a New York City Police detective, would go on to form an organization devoted to investigating the UFO phenomena, called the &#8220;Scientific Bureau of Investigation.&#8221;</p>
<p>American and Viet Cong forces were not even the only victims of such frightening occurrences. On the evening of August 12, 1968, a team of engineers from the Soviet Union were near the remote area of Cao Bang, North Vietnam, working on plans to build a hydroelectric plant there. As they went about their duties a deep rumbling echoed out from above to reverberate through the area, and they feared that it was possibly an American B-52 bomber making a deadly run. The frightened Soviet engineers scurried to their tents to hide, and that was where they saw something quite odd indeed.</p>
<p><img class="aligncenter size-large wp-image-80047" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/black-sphere-570x428.jpg" alt="" width="570" height="428" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/black-sphere-570x428.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/black-sphere-300x225.jpg 300w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/black-sphere-768x576.jpg 768w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/black-sphere.jpg 1600w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>There hovering in the middle of their tent was an angular, diamond-shaped object which was described as being a deep black in color and glowing with a greenish-blue light. The bizarre floating object made no sound or movement, just hanging there with its inscrutable, unknowable purpose. Before they could even process what they were seeing there was a sudden burst of light and a shockwave that tossed everyone to the ground. The explosion destroyed the tent and scattered their equipment everywhere, destroying or heavily damaging most of it. The men themselves had managed to survive without injury, but were still deeply shaken by the strange event and excitedly consorted with each other about what had just happened. When they tried to call their base they found that no communications equipment seemed to work, leaving them in complete isolation out there in the dark with some unknown, possibly hostile force circling around them in the dim jungle.</p>
<p>The next morning, after a night with very little sleep, the radio was found to be in working condition again and they were able to report on what had happened to them the previous evening before continuing with their mission. Two days later, the team of engineers made a rather odd discovery when they stumbled across a black sphere around 3 meters across, lying 1 km from their camp. The bizarre sphere had many weird qualities, in that it did not cast a shadow and did not reflect any light. The surface of the sphere was apparently smooth to the touch and could not be damaged by a knife scraped across it. Upon radioing in their find the team was told by headquarters to move 20 meters away from the object and await further instruction, which they did, setting up a camp precisely 20 meters away from the inscrutable object.</p>
<p>That night, one of the engineers got up and ventured out into the forest, but no one really thought much of it, thinking he was just going out to relieve himself. When the man did not return, the others then nervously called out his name, very aware that that otherworldly sphere was still looming out there in the darkness. With no response, they warily got some flashlights and fanned out into the night to search for their comrade but could not find him. An hour later, another one of the men also reportedly got up and headed out into the brush in the same direction that the first had gone, toward the sphere as a matter of fact, and this time the man was noticed to be moving as if in a trance or daze. He too did not return.</p>
<p><img class="aligncenter size-large wp-image-80046" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/black_sphere_by_txvirus-d4ngrt7-570x405.jpg" alt="" width="570" height="405" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/black_sphere_by_txvirus-d4ngrt7.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/black_sphere_by_txvirus-d4ngrt7-300x213.jpg 300w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/black_sphere_by_txvirus-d4ngrt7-164x116.jpg 164w" sizes="(max-width: 570px) 100vw, 570px"/></p>
<p>The remaining men were by this time terrified, and decided to just wait at the camp rather than venture once more out into that unknown night, but the strangeness was not over, as yet another man wandered off into the wilderness, leaving only two of the engineers remaining there huddled in the flickering, dancing flames of their campfire. As they sat there, one of them stood up in a disjointed way as the other looked on in horror and he too stumbled off into the night. This was all so disturbing to the remaining engineer that he purportedly shot himself in the leg with his side arm just to prevent himself from being beckoned by whatever ominous force was drawing them in one by one. The pain and shock from this self-inflicted wound caused him to pass out as thoughts of those dazed men and that sphere danced about in his head. The next morning, the sole remaining engineer was awoken by a Soviet special forces team, and although he had lost quite a lot of blood he was still alive. He told the soldiers about the sphere and what had happened during the night, but no trace of any such object or the missing men could be found. Whatever happened here and what that black sphere was remain a mystery.</p>
<p>There has been at least one case where a whole military base has been the apparent target of some sort of otherworldly attack during the Vietnam War. In 1966, the American base at Nha Trang, of South Vietnam, a huge, heavily defended base with around 2,000 American troops and thousands more South Vietnamese personnel, would become ground zero for one of the most spectacular UFO incidents of the entire war, and also one of the most unsettling. On one quiet evening that was unmarred by any incident, soldiers were outdoors watching a projected movie powered by diesel generators and enjoying the rare moment of peace and entertainment when there was suddenly a light that crept up into the sky over a ridge to the north. The strange object was at first thought to be a flare, but this idea was soon put to rest when it began to move, change speeds, and hover, the whole time casting an incredibly brilliant luminescence. Then it began to work its way in the direction of the base. This was certainly no flare. One witness would say:</p>
<blockquote><p>It came from the north and was moving from real slow to real fast. Pilots on the base estimated the lights were about 25,000 feet high. Then the panic broke loose. It dropped right towards us and stopped dead still about 300 to 500 feet up. It made this little valley and the mountains around look like it was the middle of the day; it lit up everything. Then it went up and I mean up. It went straight up and completely out of sight in about 2-3 seconds. Everybody is still talking about it.</p></blockquote>
<div id="attachment_80044" class="wp-caption aligncenter"><img class="size-large wp-image-80044" src="http://mysteriousuniverse.org/wp-content/uploads/2017/02/7741606-570x384.jpg" alt="" width="570" height="384" srcset="http://mysteriousuniverse.org/wp-content/uploads/2017/02/7741606.jpg 570w, http://mysteriousuniverse.org/wp-content/uploads/2017/02/7741606-300x202.jpg 300w" sizes="(max-width: 570px) 100vw, 570px"/><p class="wp-caption-text">The base at Nha Trang</p></div>
<p>What made the whole scene somewhat menacing was that as the light descended upon them every single electric generator on the base stopped working in unison, sending them into complete darkness. Even trucks, cars, 8 bulldozers that had been at work, and two planes that had been preparing to take off stopped operating, their engines rendered lifeless by some unknown force. Nothing worked and there was a complete blackout as the light inexorably drew closer and troops ran about in a panic. Then suddenly the light shot up at great velocity into the sky and was gone. This was witnessed by hundreds, possibly thousands of troops, and one witness said of the spooky scene:</p>
<blockquote><p>The engines on two planes that were the runway ready to take off stopped, and there wasn&#8217;t a car, truck, plane or anything that ran for about four minutes. Then it went up and I mean up. It went straight up and completely out of sight in about 2-3 seconds. A whole plane load of big shots from Washington got here this afternoon to investigate. It&#8217;s on the radio over here. I swear if somebody says they saw a little green man I won&#8217;t argue with them.</p></blockquote>
<p>A lot of theories have swirled about the presence of mysterious unidentified aircraft and seemingly alien forces and their sightings and engagements during the war. Misidentifications, experimental aircraft, stress and tiredness, and even hallucinations caused by drugs such as LSD have often been put forward to try and rationalize what all of these personnel were experiencing during the war, on both sides of the conflict. However, many of these accounts were fully witnessed by numerous people, both American forces and the North Vietnamese, often at the same time, so can this be so easily dismissed out of hand as something so mundane? Do such large numbers of trained personnel hallucinate the same thing at the same time and would they open fire on or engage such hallucinations? Of course there is also the possibility that at least some of these reports were exaggerations, fabrications, or fictitious reports passed down the line as fact, either entirely made up or starting as based in fact only to be warped by retellings into something stranger than they are. Indeed many of these accounts seem to be very hard to officially verify, although with the amount of cover-ups allegedly being actively sought on such matters it is perhaps easy to see why this may be. It is hard to say what the case may be, in many cases the facts hazy and ill-defined.</p>
<p>Is there anything to any of these events? For now true concrete answers remain murky, and we can only guess at what lies behind such spectacular accounts of fighting between these men and something that evades easy explanation. It is uncertain if any of these reports originate in nerves, hallucinations, aircraft from earth, or something else. It cannot even be known for sure if these cases ever really happened as described or not. What is certain is that he Vietnam War was truly a terrifying, often strange place to be for those who served there, and whether one believes them or not these stories of spooky encounters with UFOs and things beyond our understanding certainly add another layer to all of the fear, confusion, and weirdness of it all.</p>
<p class="tags"><span>&nbsp;</span><strong>TAGS: </strong><a href="http://mysteriousuniverse.org/tag/alien-attack/" rel="tag">Alien Attack</a>, <a href="http://mysteriousuniverse.org/tag/aliens/" rel="tag">aliens</a>, <a href="http://mysteriousuniverse.org/tag/bizarre/" rel="tag">Bizarre</a>, <a href="http://mysteriousuniverse.org/tag/conspiracy/" rel="tag">Conspiracy</a>, <a href="http://mysteriousuniverse.org/tag/modern-mysteries/" rel="tag">modern mysteries</a>, <a href="http://mysteriousuniverse.org/tag/ufo-attack/" rel="tag">UFO attack</a>, <a href="http://mysteriousuniverse.org/tag/ufo-in-war-zone/" rel="tag">UFO in war zone</a>, <a href="http://mysteriousuniverse.org/tag/ufos/" rel="tag">UFOs</a>, <a href="http://mysteriousuniverse.org/tag/unexplained-phenomena/" rel="tag">unexplained phenomena</a>, <a href="http://mysteriousuniverse.org/tag/unsolved-mystery/" rel="tag">unsolved mystery</a>, <a href="http://mysteriousuniverse.org/tag/vietnam-war/" rel="tag">Vietnam War</a>, <a href="http://mysteriousuniverse.org/tag/war/" rel="tag">war</a>, <a href="http://mysteriousuniverse.org/tag/war-mysteries/" rel="tag">war mysteries</a></p> </div>
<div class="post-footer-ad">
<div id="text-3" class="widget widget_text"> <div class="textwidget"><div id="ld-650-6959"></div><script data-cfasync="false">(function(w,d,s,i){w.ldAdInit=w.ldAdInit||[];w.ldAdInit.push({slot:8747465604094567,size:[0, 0],id:"ld-650-6959"});if(!d.getElementById(i)){var j=d.createElement(s),p=d.getElementsByTagName(s)[0];j.async=true;j.setAttribute("data-cfasync","false");j.src="//cdn2.lockerdome.com/_js/ajs.js";j.id=i;p.parentNode.insertBefore(j,p);}})(window,document,"script","ld-ajs");</script></div>
</div> </div>
</div>
 
<div class="blue-holder">
<div class="inner">
 
<div class="related-articles">
<a href="http://mysteriousuniverse.org/tag/alien-attack/" class="view-all">VIEW ALL</a>
<h3>Related Articles</h3>
<div class="col">
<div class="related-article-container">
<a href="http://mysteriousuniverse.org/2015/05/ufo-seen-over-nepal-as-mt-everest-shrinks/"><img width="166" height="106" src="http://mysteriousuniverse.org/wp-content/uploads/2015/05/UFO-screenshot-166x106.png" class="img wp-post-image" alt=""/></a> <h5><a href="http://mysteriousuniverse.org/2015/05/ufo-seen-over-nepal-as-mt-everest-shrinks/">UFO Seen Over Nepal As Mt. Everest Shrinks</a></h5>
<p>A UFO was recorded hovering over areas of Nepal devastated by the recent earthquake at the same time as new images taken by a European Space Agency radar satellite show that Mt&#8230;.</p>
<div class="cl">&nbsp;</div>
</div>
<a href="http://mysteriousuniverse.org/2015/05/ufo-seen-over-nepal-as-mt-everest-shrinks/" class="more">Read More</a>
<p class="comments"><a href="http://mysteriousuniverse.org/2015/05/ufo-seen-over-nepal-as-mt-everest-shrinks/#comments"><span class="dsq-postid" data-dsqidentifier="44358 http://mysteriousuniverse.org/?p=44358"><span>&nbsp;</span>4</span></a></p>
</div>
<div class="col">
<div class="related-article-container">
<a href="http://mysteriousuniverse.org/2016/08/attack-of-the-blood-sucking-killer-mosquito-tornadoes/"><img width="166" height="106" src="http://mysteriousuniverse.org/wp-content/uploads/2016/08/mosquito-tornadoes-166x106.jpg" class="img wp-post-image" alt=""/></a> <h5><a href="http://mysteriousuniverse.org/2016/08/attack-of-the-blood-sucking-killer-mosquito-tornadoes/">Attack of the Blood-Sucking Killer Mosquito Tornadoes</a></h5>
<p>Sharks may have the reputation, star in the best movies and inspire the scariest music, but the creature that kills more humans annually  than even humans do is the tiny mosquito. As&#8230;</p>
<div class="cl">&nbsp;</div>
</div>
<a href="http://mysteriousuniverse.org/2016/08/attack-of-the-blood-sucking-killer-mosquito-tornadoes/" class="more">Read More</a>
<p class="comments"><a href="http://mysteriousuniverse.org/2016/08/attack-of-the-blood-sucking-killer-mosquito-tornadoes/#respond"><span class="dsq-postid" data-dsqidentifier="68591 http://mysteriousuniverse.org/?p=68591"><span>&nbsp;</span>0</span></a></p>
</div>
<div class="col">
<div class="related-article-container">
<a href="http://mysteriousuniverse.org/2016/08/whales-may-hold-secret-to-menopause-and-mammas-boys/"><img width="166" height="106" src="http://mysteriousuniverse.org/wp-content/uploads/2016/08/760f65_fba25fe14dc5cd01510c85f42ed7284e-166x106.jpg" class="img wp-post-image" alt=""/></a> <h5><a href="http://mysteriousuniverse.org/2016/08/whales-may-hold-secret-to-menopause-and-mammas-boys/">Whales May Hold Secret to Menopause and Mamma&#8217;s Boys</a></h5>
<p>Animals are essentially born to reproduce and die, except for three species who live long enough to experience menopause. Humans, short-finned pilot whales and killer whales (orcas) live far beyond their reproductive&#8230;</p>
<div class="cl">&nbsp;</div>
</div>
<a href="http://mysteriousuniverse.org/2016/08/whales-may-hold-secret-to-menopause-and-mammas-boys/" class="more">Read More</a>
<p class="comments"><a href="http://mysteriousuniverse.org/2016/08/whales-may-hold-secret-to-menopause-and-mammas-boys/#comments"><span class="dsq-postid" data-dsqidentifier="67705 http://mysteriousuniverse.org/?p=67705"><span>&nbsp;</span>1</span></a></p>
</div>
</div>
 
<div id="disqus_thread">
</div>
<script type="text/javascript">
var disqus_url = 'http://mysteriousuniverse.org/2017/02/mysterious-otherworldly-military-engagements-in-the-vietnam-war/';
var disqus_identifier = '79731 http://mysteriousuniverse.org/?p=79731';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'mysteriousuniverse';
var disqus_title = "Mysterious Otherworldly Military Engagements in the Vietnam War";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=79731';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
</div>
<div class="bottom">&nbsp;</div>
</div>
</div>
<div class="bottom">&nbsp;</div>
</div>
 
</div>
 
 
<div id="sidebar">
<div id="theme-widget-ads-6" class="widget theme-widget">  
<div class="banners big">
<div class="cfmonitor" style="padding-bottom: 10px;"><script type="text/javascript">// <![CDATA[
google_ad_client = "ca-pub-4693692690710487";
/* Right Sidebar Top */
google_ad_slot = "6052779926";
google_ad_width = 300;
google_ad_height = 250;
// ]]&gt;</script><script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js">// <![CDATA[


// ]]&gt;</script></div>
<div style="padding-left: 20px; padding-bottom: 10px;"> </p>
<div class="bsarocks bsap_a3d581099f492b46baa9b3edabd503b9" id="bsap_1262711"></div>
<p> </p>
<p class="ad small aligncenter"><a href="http://bsa.ly/bn8">Advertise above with BuysellAds</a></p>
</div>
<div class="cfmonitor">
<script type="text/javascript">// <![CDATA[
google_ad_client = "ca-pub-4693692690710487";
/* Right Sidebar - text and rich media */
google_ad_slot = "6936119127";
google_ad_width = 300;
google_ad_height = 250;
// ]]&gt;</script><script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div>
</div>
<div class="cl">&nbsp;</div></div><div id="theme-widget-ads-7" class="widget theme-widget"></div><div id="theme-widget-voicemail-6" class="widget theme-widget"> <div class="call-box">
<h5>Call Our voicemail</h5>
<p>
<strong>+1 (530) 918 4070</strong> or Skype: <strong>MysteriousUniv</strong> </p>
</div>
</div><div id="theme-widget-latest-tweets-6" class="widget theme-widget"> <div class="twitter-box">
<div class="top notext">&nbsp;</div>
<div class="entry">
<h4>Follow Us On Twitter</h4>
<p>Allan Hendry and the Case for Scientific Study of UFOs - <a href="https://t.co/Spg50jOtXq" target="_blank">https://t.co/Spg50jOtXq</a> <a href="https://t.co/VTzVSksbFn" target="_blank">https://t.co/VTzVSksbFn</a></p>
<p class="details">@mysteriousuniv - about 1 hour ago</p>
<a href="https://twitter.com/mysteriousuniv" class="twitter-follow-button" data-show-count="false">Follow @mysteriousuniv</a>
<script type="text/javascript">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
<div class="bottom notext">&nbsp;</div>
</div>
</div><div id="categories-8" class="widget widget_categories"><h4 class="widgettitle">Categories</h4> <ul>
<li class="cat-item cat-item-39"><a href="http://mysteriousuniverse.org/category/ancient/">Ancient Mysteries</a>
</li>
<li class="cat-item cat-item-43"><a href="http://mysteriousuniverse.org/category/bizarre/">Bizarre</a>
</li>
<li class="cat-item cat-item-45"><a href="http://mysteriousuniverse.org/category/conspiracy/">Conspiracy</a>
</li>
<li class="cat-item cat-item-38"><a href="http://mysteriousuniverse.org/category/cryptozoology/" title="Animals which are considered to be legendary or otherwise nonexistent by mainstream biology.">Cryptozoology</a>
</li>
<li class="cat-item cat-item-1472"><a href="http://mysteriousuniverse.org/category/entertainment/">Entertainment</a>
</li>
<li class="cat-item cat-item-40"><a href="http://mysteriousuniverse.org/category/ghostshauntings/">Ghosts &amp; Hauntings</a>
</li>
<li class="cat-item cat-item-42"><a href="http://mysteriousuniverse.org/category/modernmystery/">Modern Mysteries</a>
</li>
<li class="cat-item cat-item-36"><a href="http://mysteriousuniverse.org/category/munews/" title="Only for news and updates on the site and podcast. E.G upcoming guest announcements, schedules, downtime etc">MU News</a>
</li>
<li class="cat-item cat-item-47"><a href="http://mysteriousuniverse.org/category/naturalworld/" title="New animal discoveries etc">Natural World</a>
</li>
<li class="cat-item cat-item-2329"><a href="http://mysteriousuniverse.org/category/news/" title="All the latest weird news!">News</a>
</li>
<li class="cat-item cat-item-1417"><a href="http://mysteriousuniverse.org/category/plus-articles/">Plus+ Articles</a>
</li>
<li class="cat-item cat-item-235"><a href="http://mysteriousuniverse.org/category/plus-podcasts/">Plus+ Podcasts</a>
</li>
<li class="cat-item cat-item-32"><a href="http://mysteriousuniverse.org/category/podcasts/">Podcasts</a>
</li>
<li class="cat-item cat-item-2572"><a href="http://mysteriousuniverse.org/category/psychedelics/">Psychedelics</a>
</li>
<li class="cat-item cat-item-41"><a href="http://mysteriousuniverse.org/category/scitech/">Science &amp; Technology</a>
</li>
<li class="cat-item cat-item-46"><a href="http://mysteriousuniverse.org/category/spaceastronomy/">Space &amp; Astronomy</a>
</li>
<li class="cat-item cat-item-44"><a href="http://mysteriousuniverse.org/category/spirituality/">Spirituality</a>
</li>
<li class="cat-item cat-item-37"><a href="http://mysteriousuniverse.org/category/ufo-phenomenon/" title="UFO Sightings, accounts, MOD releases, etc.. ">UFO Phenomenon</a>
</li>
<li class="cat-item cat-item-2330"><a href="http://mysteriousuniverse.org/category/video/" title="Interesting videos that will make you laugh and gasp.">Video</a>
</li>
</ul>
</div></div>
 
<div class="cl">&nbsp;</div>
</div>
 
</div>
 
<div class="footer notext">&nbsp;</div>
</div>
 
 
<div id="footer">
<div class="top">
 
<div class="shell">
<div class="left text">
<h5>About Mysterious Universe</h5>
<p>Mysterious Universe brings you the latest news and podcasts covering the strange, extraordinary, weird, wonderful and everything in between.</p>
<p>The Mysterious Universe podcast debuted in 2006 and has since grown to a huge following with millions of downloads from around the world.</p>
<p>Get to know the <a href="/about">MU Team</a> over on our <strong><span style="text-decoration: underline;"><a href="http://mysteriousuniverse.org/about/">About page</a></span></strong> and be sure to checkout out our <strong><span style="text-decoration: underline;"><a href="http://mysteriousuniverse.org/category/podcasts/">Podcasts</a></span></strong> while you're here.<br/>
 </p>
<div class="g-plusone" data-size="small" data-annotation="inline" data-width="300"></div>
<p> <br/>
<script type="text/javascript">// <![CDATA[
(function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
// ]]></script></p>
</div>
<div class="left site-info">
<h5>Site Info</h5>
<ul id="menu-site-info" class="menu"><li id="menu-item-14553" class="mu-plus-item menu-item menu-item-type-post_type menu-item-object-page menu-item-14553"><a href="http://mysteriousuniverse.org/plus/">Join MU</a></li>
<li id="menu-item-14624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14624"><a href="http://mysteriousuniverse.org/about/">About</a></li>
<li id="menu-item-14603" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14603"><a href="http://mysteriousuniverse.org/faq/">Frequently Asked Questions</a></li>
<li id="menu-item-14555" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14555"><a href="http://mysteriousuniverse.org/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-14556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14556"><a href="http://mysteriousuniverse.org/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-19600" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19600"><a href="http://mysteriousuniverse.org/advertisers/">Advertisers</a></li>
<li id="menu-item-26785" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26785"><a href="http://mysteriousuniverse.org/app/mu-app-version/">MU App Version Notes</a></li>
</ul> <div class="socials">
<ul>
<li><a href="https://www.facebook.com/mysteriousuniv" class="facebook-link" target="_blank">Facebook</a></li>
<li><a href="http://twitter.com/mysteriousuniv" class="twitter-link" target="_blank">Twitter</a></li>
</ul>
</div>
</div>
<div class="left buy">
<h5>Buy the Podcast Back Catalogue</h5>
<h6><img class="alignleft" alt="" src="http://mysteriousuniverse.org/wp-content/themes/mysterious-universe/images/catalogue.png"/>The Mega Value Pack</h6>
<p class="price"><a href="http://store.mysteriousuniverse.org/catalog/mega-value-pack/" class="purchase-button">Purchase</a>$99<span>.00</span></p>
<p>Get the entire collection<br/>
now for this great price.</p>
</div>
</div>
 
</div>
<div class="bottom">
 
<div class="shell">
<p class="copy left">Copyright &copy; Mysterious Universe. Mysterious Universe is a property of 8th Kind Pty Ltd</p>
<div class="links right">
<ul id="menu-bottom-bar-menu" class="menu"><li id="menu-item-14545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14545"><a href="http://mysteriousuniverse.org/wp-login.php">Login</a><span>|</span></li>
<li id="menu-item-14546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14546"><a href="http://mysteriousuniverse.org/contact-us/">Contact Us</a><span>|</span></li>
</ul> </div>
<div class="cl">&nbsp;</div>
</div>
 
</div>
</div>
 
<script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'mysteriousuniverse';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
<script type="text/javascript">
				function get_stripe_vars() {
					return eval( '(' + '{"cancelmessage":"Are you sure you want to cancel your subscription?","nonceinvoices":"8ce58c6a69","nonceinvoicedetail":"f12d1a0327","noncecoupon":"e69573d207","noncecoupondetail":"c89702abb6","stripethankyouurl":"http:\/\/mysteriousuniverse.org\/index.php\/register\/"}' +')');
				}
			</script>
<script type="text/javascript">
jQuery(function($) {
});
</script>
<script type='text/javascript' src='http://mysteriousuniverse.org/wp-content/plugins/q-and-a/js/q-a-plus.js?ver=1.0.6.2'></script>
<script type='text/javascript' src='http://mysteriousuniverse.org/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://mysteriousuniverse.org/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'> 
 jQuery(function($) { 
 });
 </script>
</body>
</html>
